Weird Problem with Nissan Patrol 4.2TD

Submitted: Thursday, Aug 29, 2013 at 20:38
ThreadID: 104100 Views:11182 Replies:8 FollowUps:8
This Thread has been Archived
Hi Everyone,

Need some help/advice please.
Two days ago I went to start the Patrol (2005 model) to come home from hobby farm and no go …..just cranked and cranked (has always started instantly first turn of key). Called motoring body for road side assist. Primed fuel in case of air lock…still not firing up …just continuous cranking. Towed vehicle to nearest diesel mechanic (who also accessed an auto electrician) . They had no luck either…but discovered the red immobilizer light on dash (near windscreen) stayed on after ignition was turned on. Tiltrayed to Nissan dealer today …. News not good. Appears the immobilizer control unit has a problem and this is located under the dash on firewall. About 6 hours labour to remove console, dash, wiring harness, and diagnostically test unit etc etc. Work to begin tomorrow.
Questions: has anyone with a 4.2TD Nissan had this problem (or heard of it happening)? Any advice or suggestions or advice. Seems weird that Nissan would build a vehicle with a component so inaccessible if it can fail. Is anyone aware of an alternative solution…maybe bypass the immobilizer system altogether? If so how can it be done. Vehicle has already been towed twice so I really don’t want to have to go any where else. It appears only a Nissan dealer knows how to fix this problem anyway.

Cheers

Back Expand Un-Read 0 Moderator

Reply By: donk - Thursday, Aug 29, 2013 at 20:52

Thursday, Aug 29, 2013 at 20:52
It could possibly be the csolu on the rear of the injector pump (happens on 100 series cruisers as well)

This is from the Nissan Patrol Forum

The solenoid you will be after is called the Csolu which I think stands for coded solenoid. I have just been through replacing mine from a lightning strike. You can get this solenoid seperate from Bosch mine was $650 (it was supplied through the Nissan dealer) if the dealer you see tells you they can't. Nissan don't sell the pump and solenoid seperately only together I was quoted $7000.
As much as I hate to suggest this you should look at taking it to a Nissan dealer and get them to plug into the Nats system the diagnosis plug is below your steering wheel. They can tell you what component is playing up. You have said that your nats light has been staying on so there is something wrong with the nats system. The nats system on the TD42TI comprises of the key reading antenna (in the steering column), the Immu (the computer which is behind the aircon evaporater on the passenger side pretty impossible to get to without ripping out the dash) and the Csolu (on the pump). You do have a option though if you don't want the nats system. You will need to remove your pump and drill out the 3 anti theft bolts holding the Csolu on. When removed the standard fuel solenoid is below it, there are 3 wires going to the Csolu brown, green and black (I think bad memory). The green is from the Immu and sends the signal to the Csolu that the right key is in the ignition and the car can be started. I think there should be a brown and black wire going into the standard fuel solenoid (or possibly just the brown like my old GQ as they don't have Nats I didn't see my solenoid). Just wire the brown and black (if it has a black) wires to the fuel solenoid and leave the green wire as there will be no place for it just make sure it can't be grounded. The brown wire is 12v straight from the ignition, the black wire is an earth. You can check that it is working before you put the pump back in by turning on your ignition and the fuel solenoid should activate. This is just a suggestion though, it's entirely your decision if you decide to do it. I'm sure there will be others on the forum who might suggest what I have written is wrong or correct.

Regards Don



AnswerID: 517274

Follow Up By: Member - Wamuranman - Thursday, Aug 29, 2013 at 21:02

Thursday, Aug 29, 2013 at 21:02
Thanks Donk.
I will ask if they have checked the csolu first.
They run some tests today and the faults apparently directed them to the immobilizer control unit.
It seems like a Nissan dealer is the only way to go on this one.
Cheers
0
FollowupID: 796917

Follow Up By: Ozhumvee - Thursday, Aug 29, 2013 at 21:08

Thursday, Aug 29, 2013 at 21:08
I know of one that had the same problem as the one in Donks thread and they did as that bloke suggested and bypassed the immobiliser system completely. Just fitted a hidden switch to turn the fuel solenoid on and off manually to achieve the same end.
Peter
1996 Oka Motorhome

Member
My Profile  My Position  Send Message

0
FollowupID: 796919

Follow Up By: Member - Wamuranman - Thursday, Aug 29, 2013 at 21:17

Thursday, Aug 29, 2013 at 21:17
I would be happy to bypass the immobilizer altogether but I am now at a Nissan dealer and I doubt whether they would be party to that method. I wish I had asked this question earlier.

Thanks for comments

0
FollowupID: 796922

Follow Up By: Ozhumvee - Thursday, Aug 29, 2013 at 21:29

Thursday, Aug 29, 2013 at 21:29
If it starts getting very expensive, they come back and want silly money to replace immobiliser or the doover on the pump you can always call a halt and have it towed to somewhere else like home if you are mechanically minded to do the work.
Peter
1996 Oka Motorhome

Member
My Profile  My Position  Send Message

0
FollowupID: 796923

Follow Up By: Member - Ian W1 (QLD) - Friday, Aug 30, 2013 at 07:16

Friday, Aug 30, 2013 at 07:16
Hi, totally agree with Don. My 2004 GU4.2TD1 had the same issue at a local shopping centre. Tried spare key (hoping it might be just the security battery flat) but finished up getting it towed to a guy who knew exactly what the problem was....bypassed the solenoid got it going and charged just on $400.00. No way you would get the car going if you were in the middle of no-where but according to the mechanic who fixed mine, it's not an uncommon problem with 4.2TDi's. The red light on the dash still flashes to give the impression the NATS is still working - only minor problem is that it flashes all the time, even when the ignition is on and engine running. Don't go spending $7000! Cheers
0
FollowupID: 796940

Follow Up By: Member - Wamuranman - Friday, Aug 30, 2013 at 07:56

Friday, Aug 30, 2013 at 07:56
Ian W1,
Are you able to send me the contact details of the guy who fixed yours for $400. I see you are in Qld so maybe if I need to I can go the same way if Nissan want big $s to fix.
You can send me a message or email me on :
havilahheights@aapt.net.au

Thanks

0
FollowupID: 796942

Follow Up By: Member - Ian W1 (QLD) - Friday, Aug 30, 2013 at 08:23

Friday, Aug 30, 2013 at 08:23
Hi, sent PM to you...hope you can get fixed at a reasonable cost. Cheers
1
FollowupID: 796945

Reply By: Member - LeighW - Thursday, Aug 29, 2013 at 21:59

Thursday, Aug 29, 2013 at 21:59
If you have a spare key try it, my partner had a similar problem with her
honda, after playing around with the immobiliser I noticed the key symbol
on the dash was not going off, grabbed her spare key and tried it car started

Chip in key had gone to god.

Cheers
Leigh

Lifetime Member
My Profile  Send Message

AnswerID: 517282

Follow Up By: Robin Miller - Friday, Aug 30, 2013 at 07:39

Friday, Aug 30, 2013 at 07:39
Something Similar Leigh

This wasn't Nissans problem , but when I got my new petrol patrol and had a spare key cut the car wouldn't start with it.
Turned out key was cut but chip wasn't programmed.

Problem was solved pretty quickly - however I found it useful to be able to rotate the engine without it firing.

Hence I went and got a key cut without a chip in it for $10.

Can be quite a useful tool (more so in the manual car as you can also move the car without firing the engine).
Robin Miller

Member
My Profile  Send Message

0
FollowupID: 796941

Reply By: Member - Rob D (NSW) - Thursday, Aug 29, 2013 at 22:06

Thursday, Aug 29, 2013 at 22:06
I had a similar problem some years ago. I disconnected the battery(s) completely and then re-connected them and the problem was solved.

I hope that your problem is this simple.

Best of luck.
If you relax at a faster pace you can get more relaxation in for a given time.
Regards Rob

Lifetime Member
My Profile  My Blog  Send Message

AnswerID: 517283

Reply By: Member - cherrywipe - Thursday, Aug 29, 2013 at 22:25

Thursday, Aug 29, 2013 at 22:25
Hi,
Had similar with my 2000 4.2. Wouldn't start,bled the fuel, called out the R.A.A.
He asked if we had a spare key tried that and motor fired up,seems the chip or whatever it's called had fallen out of the key. We later found it on the ground in front of store,glued it in and still working..
AnswerID: 517285

Reply By: bigcol - Thursday, Aug 29, 2013 at 23:34

Thursday, Aug 29, 2013 at 23:34
Wifes Dogwooo wouldn't start the other day.
Went to the closest Holden dealer on a tilt tray.
Thousands to fix the immobilizer or a hundred for the diagnosis and the by-passing of it.
New immobilizer is worth more than the car
Tilt Tray driver was on first name terms with the service manager.
I asked him why and he said he always bringing in new Cruzes and Captivas that have broken down.
AnswerID: 517289

Reply By: zook - Friday, Aug 30, 2013 at 08:28

Friday, Aug 30, 2013 at 08:28
Hi Wamuranman,

I had an issue like that a while ago. Got road side assist out and they just bypassed the immobiliser and never had any difficulties after that. May have been lucky that roadside assist were prepared to bypass it but it didn't take him very long and patrol just fired straight up after it was bypassed.

Zook
AnswerID: 517298

Reply By: Motherhen - Friday, Aug 30, 2013 at 23:17

Friday, Aug 30, 2013 at 23:17
Have you solved the problem yet Wamuranman? While we have not had trouble with the immobilising system in our 3 litre Nissan Patrol, we have with the after market immobilisers in other cars. Taking the fuse on the immobiliser out and replacing it resets the after market immobiliser in my car when it plays up.

Motherhen
Motherhen

Red desert dreaming

Lifetime Member
My Profile  My Blog  Send Message

AnswerID: 517376

Reply By: Member - Wamuranman - Saturday, Aug 31, 2013 at 08:27

Saturday, Aug 31, 2013 at 08:27
Thanks to all who replied and provided valuable information.

The problem is not fixed yet Motherhen as yesterday was a day of phonecalls and research.
But we have pulled the plug at getting Nissan to fix it by pulling the dash out etc etc.
On Monday we are having it towed (3rd time) to a diesel injector specialist at Caboolture who has done the bypass on others in the past.
(thanks to Ian W1 for the info but Goodna is a bit far from where we are, thus my time yesterday reseraching out injector specialists on the northside who have done this bypass).
The injector pump comes off to fix and some electrical work. Estimated cost about $500. (but a lot cheaper than the Nissan dealership alternative).
Apparently its a lot more common in the 4.2TD patrol than I thought and will probably occur more often as the vehicle ages.
The good news for me is that with the bypass the problem can never re-occur in a remote area and let us down. We have been so lucky this problem did not occur 2 weeks ago when we were 120km south of Winton towing our caravan to Opalton to go fossicking. We did not even have mobile coverage there.
We were so lucky ... the failure occurred the 3rd time the vehicle was started after we got home last Sunday!!!!!.

Cheers
AnswerID: 517391

Sponsored Links

Popular Products (13)