Comment: Embed Tracking on Your Site

For some reason the embedded dynamic map for my EOTrackMe is not working. I can get the embedded image, but not the dynamic map. The current tracking on my profile Tab is correct.
Back Expand Un-Read 0 Moderator

Reply By: ExplorOz - David & Michelle - Wednesday, Dec 24, 2014 at 01:23

Wednesday, Dec 24, 2014 at 01:23
AngusCS,

Can you point me to the page you are loading the embed code onto so I can test it from this end.

David
David (DM) & Michelle (MM)
---------------------------------
Always working not enough travelling!

Lifetime Member
My Profile  My Blog  My Position  Send Message
Moderator

AnswerID: 543315

Follow Up By: Member - AngusCS - Wednesday, Dec 24, 2014 at 09:59

Wednesday, Dec 24, 2014 at 09:59
David, Thank you. You can look at the images on my profile under the get embed code (if you can get into my Profile), or you could have a quick look at a test page I have created at http://crampton-smith.com/EOTest.html. Gus
0
FollowupID: 830287

Follow Up By: Member - AngusCS - Wednesday, Dec 24, 2014 at 12:10

Wednesday, Dec 24, 2014 at 12:10
David, I tried to open it in Chrome (thinking it might be a Java thing), and did some debug. There are errors for each of the Dynamic Map iFrames on that page that say:


http://www.exploroz.com/EOTrackMe/Services.asmx/getDeviceTrack Failed to load resource: the server responded with a status of 500 (Internal Server Error)

Embed_Map.aspx:42
Uncaught ReferenceError: SiteName is not defined

and looking a little deeper:

jquery.min.js:2 POST http://www.exploroz.com/EOTrackMe/Services.asmx/getDeviceTrack 500 (Internal Server Error)jquery.min.js:2 sendjquery.min.js:2 v.extend.ajaxEmbed_Map.aspx?bm=2&d=065QbDkxboXg22n86GUPEQeuauruGOYBi:146
loadTracking

Embed_Map.aspx?bm=2&d=065QbDkxboXg22n86GUPEQeuauruGOYBi:193 (anonymous function)
jquery.min.js:2 l
jquery.min.js:2 c.fireWith
jquery.min.js:2 v.extend.ready
jquery.min.js:2 A
Embed_Map.aspx?bm=2&d=065QbDkxboXg22n86GUPEQeuauruGOYBi:42
Uncaught ReferenceError: SiteName is not defined
Embed_Map.aspx?bm=2&d=065QbDkxboXg22n86GUPEQeuauruGOYBi:42 showSystemStatusMsgEmbed_Map.aspx?bm=2&d=065QbDkxboXg22n86GUPEQeuauruGOYBi:150 $jq.ajax.error
jquery.min.js:2 l
jquery.min.js:2 c.fireWith
jquery.min.js:2 T
jquery.min.js:2 r
0
FollowupID: 830290

Follow Up By: Member - AngusCS - Thursday, Dec 25, 2014 at 08:32

Thursday, Dec 25, 2014 at 08:32
So I have now tried this in the following Browser/OS combinations...

IE 11 on Win 8.1
Chrome (latest) on Win 8.1
IE 11 on Server 2008
IE11 on Win 7
Chrome version 39.0.2171.95 m on Win 7

All seem to be failing at the same point when trying to render the Dynamic Map with an:

Uncaught ReferenceError: SiteName is not defined
0
FollowupID: 830328

Follow Up By: Member - AngusCS - Thursday, Dec 25, 2014 at 10:15

Thursday, Dec 25, 2014 at 10:15
Thus is also not working in the display image when you go to the profile page and "get Embed Code". I get the following error from IE 11
0
FollowupID: 830333

Follow Up By: ExplorOz - David & Michelle - Thursday, Dec 25, 2014 at 12:09

Thursday, Dec 25, 2014 at 12:09
Angus,

Merry Christmas just finished present opening and fixed it. Your test page all works as expected. Thanks for pointing out the problem.

David
David (DM) & Michelle (MM)
---------------------------------
Always working not enough travelling!

Lifetime Member
My Profile  My Blog  My Position  Send Message
Moderator

0
FollowupID: 830335

Follow Up By: Member - AngusCS - Thursday, Dec 25, 2014 at 12:23

Thursday, Dec 25, 2014 at 12:23
Thanks and hope Santa was good to you.
0
FollowupID: 830336

Reply By: Member - AngusCS - Thursday, Dec 25, 2014 at 11:50

Thursday, Dec 25, 2014 at 11:50
David

This is now working again on all of the different Dynamic Map Types.

Thanks Gus
AnswerID: 543363

Sponsored Links

Popular Products (13)