AGM Batteries

Submitted: Thursday, Mar 31, 2016 at 22:11
ThreadID: 131989 Views:2972 Replies:7 FollowUps:4
This Thread has been Archived
I have just fitted 2 brand new AGM batteries to my 2003 Jayco Flamingo Outback van. As soon as I turn the batteries on it blows the fuse on the Centurion 3000 (CS2000 20amp) , battery protection fuse.
I have checked all the wiring there does not appear to any problems.
All I have done is replace the batteries nothing else has been changed or replaced.
Any ideas anyone.
In Search of the Perfect Wave and not the one from the missus, ( see u later)..lol

Member
My Profile  My Blog  My Position  Send Message

Back Expand Un-Read 1 Moderator

Reply By: GREG T11 - Thursday, Mar 31, 2016 at 22:51

Thursday, Mar 31, 2016 at 22:51
When you say " on" what load are you applying to them, a fridge, lights or something else ?

AnswerID: 598039

Follow Up By: Cougar 55 - Friday, Apr 01, 2016 at 01:14

Friday, Apr 01, 2016 at 01:14
No load at all, it has duel battery isolation switch. Off 1, 2, or both.
as soon as I switch it from off to either battery it blows the fuse.
all indications are that there is a short somewhere, but all I have done is change the batteries.
In Search of the Perfect Wave and not the one from the missus, ( see u later)..lol

Member
My Profile  My Blog  My Position  Send Message

1
FollowupID: 867166

Reply By: cookie1 - Thursday, Mar 31, 2016 at 23:09

Thursday, Mar 31, 2016 at 23:09
Is the polarity of the posts on the new batteries the same as the old batteries - just a thought

cheers
AnswerID: 598041

Follow Up By: Cougar 55 - Friday, Apr 01, 2016 at 01:15

Friday, Apr 01, 2016 at 01:15
i hope so...red is positive .markings as per normal
In Search of the Perfect Wave and not the one from the missus, ( see u later)..lol

Member
My Profile  My Blog  My Position  Send Message

1
FollowupID: 867167

Follow Up By: cookie1 - Friday, Apr 01, 2016 at 12:04

Friday, Apr 01, 2016 at 12:04
New Batteries are the same voltage as the old ones - 12 Volts / 24 Volts

cheers
0
FollowupID: 867181

Reply By: Malcom M - Friday, Apr 01, 2016 at 06:40

Friday, Apr 01, 2016 at 06:40
Are the two batteries connected together all the time. ie is the switch on the combined battery output?
At least that proves you connected the batteries together correctly.

Do you possess a multimeter?
Disconnect the lead to the switch and turn it on. How big is the spark when you touch the wire to the switch. Big spark or big fuse popping implies you likely have a short in the cabling. You've either wired it incorrectly or something is touching something it shouldn't.
Check the cables for any abrasion. Maybe a cable has been rubbing on something and worn through, your disturbing things may have repositioned the damaged area so it can now touch metal.

Worst case, disconnect everything after the switch and reconnect one at a time until you find the problem wire.
AnswerID: 598049

Reply By: aussiedingo (River Rina) - Friday, Apr 01, 2016 at 08:23

Friday, Apr 01, 2016 at 08:23
check for series or parallel wiring - maybe it's 24v!
"the only thing constant in my life is change"




Member
My Profile  My Position  Send Message

AnswerID: 598052

Reply By: Allan B (Member, SunCoast) - Friday, Apr 01, 2016 at 12:13

Friday, Apr 01, 2016 at 12:13
-
Hi Cougar,

Your expressions: "it blows the fuse on the Centurion" and "as soon as I switch it from off to either battery it blows the fuse." suggest two possibilities:
1) That you may have the batteries connected in reverse polarity. I have seen references that the Centurion has 'reverse polarity protection' in a form which will blow the fuse. Double check your battery connections and don't go only by cable colour as someone previous may have screwed it up. If you have a multimeter you can also check that the battery polarity appearing at the Centurion terminals is correct. Do this with either the Centurion fuse blown or removed and the battery switch turned on. There would be markings on the Centurion terminals as to positive and negative.
2) The Centurion may have developed a fault which causes the fuse to blow when presented with the battery. Coincidental perhaps, but possible. It would need to be inspected by a competent technician.

The Centurion 3000 was never a good unit, just a simple single stage battery charger. It attracted many criticisms. If you need to replace it there are now several good alternatives with multi-stage charging which will better care for your batteries.
Cheers
Allan

Member
My Profile  My Blog  My Position  Send Message

AnswerID: 598062

Reply By: Ken - Friday, Apr 01, 2016 at 17:21

Friday, Apr 01, 2016 at 17:21
Hi, if all you have done is replace the batteries it must be a short in the wiring somewhere. Possibly not to do with this action. If the fuse blows after you switch the battery on the short must be beyond the switch where presumably you have not changed anything. All I can suggest is the act of changing the batteries has somehow caused a short but it is hard to see how this could happen !! Unless the switch is close to the batteries and somehow the load side wires have come together.

Ken
AnswerID: 598080

Reply By: Cougar 55 - Friday, Apr 01, 2016 at 17:23

Friday, Apr 01, 2016 at 17:23
Thanks all, after much climbing in, over, under and out, we have worked out by coincidence to Centurion unit is cactus.
Batteries, lights, pumps and wiring all good.
Looking at buying the Setec ST III Power supply.
Thanks for everyone's input it was very helpful
Cheers
In Search of the Perfect Wave and not the one from the missus, ( see u later)..lol

Member
My Profile  My Blog  My Position  Send Message

AnswerID: 598081

Follow Up By: Allan B (Member, SunCoast) - Friday, Apr 01, 2016 at 19:23

Friday, Apr 01, 2016 at 19:23
-
So the fault was as I suspected then.
The Setec would be a satisfactory replacement although I consider that there are others perhaps better, albeit maybe more expensive.
Good luck with it.
Cheers
Allan

Member
My Profile  My Blog  My Position  Send Message

2
FollowupID: 867199

Sponsored Links

Popular Products (13)