Tow secure system

Submitted: Sunday, Sep 25, 2016 at 17:22
ThreadID: 133498 Views:4380 Replies:2 FollowUps:0
This Thread has been Archived
Hello, I have a new C'van that comes with a tow secure (break away) system.
It gave the audible beeps to say all was operational when I picked it up about 6 weeks ago, but now it doesn't give out the audible beeps as it should.
It is hard to find much information about them, I understand that there is a battery in the controller on the van unit, which I will check out, but just wondering if anyone has come across this issue/problem before with the solution to fix it?
Cheers
Tony
"For the Rover's life has pleasures, that the townsfolk will never know" - sort of from Banjo Paterson

Lifetime Member
My Profile  My Position  Send Message

Back Expand Un-Read 0 Moderator

Reply By: TomH - Sunday, Sep 25, 2016 at 17:38

Sunday, Sep 25, 2016 at 17:38
Flat battery Is there a wire that goes from the car to it to charge it
Is quite a bit in the manual about what the beeps or lack of means.
Can be downloaded from here

http://www.rvpartsexpress.com.au/towing-equipment/brake-systems/tow-secure-break-away-kit.html
AnswerID: 604644

Reply By: Member - bbuzz (NSW) - Sunday, Sep 25, 2016 at 17:45

Sunday, Sep 25, 2016 at 17:45
Hi Sanantone,
As Tom said it will be a flat battery in the Breakaway system located in the caravan. There is a test button that will tell you this on the system cover.,
Victron, whose system I use, tell me that the power box should/can be attached to the in-house charging circuit, but seldom is.
You have to rely on driving to charge the system or use a low amp charger (4-6amp) to bring the battery back up to charge.
Its a PITA but that is what caravan manufacturers do.
bill
Bill B

Member
My Profile  Send Message

AnswerID: 604645

Sponsored Links

Popular Products (13)