Engine light 2006 rodeo

Submitted: Saturday, Oct 27, 2018 at 23:05
ThreadID: 137392 Views:878 Replies:3 FollowUps:8
Hi everyone I have just bought a 2006 turbo deisel rodeo with 222000 k's on the clock. Sometime when I'm driving the engine light flashes on and the car goes into limp mode for about a second if that but sometimes longer. It happens more after just fueling up than other times. I went for a beach run today and it was happening about about every 30 seconds to a minute. I've cleaned the maf sensor and the vsv thing and checked the earth before today but all looked good. I also have a sp tools scanner that plugs in but shows no codes. If anyone can help me that would be very appreciated cheers kyle.

Oh and also It had a full service after I bought changed the fuel filters and oil etc etc and I put some injecter /fuel systems cleaner in it but didn't do much
Back Reply Expand Un-Read 0 Moderator

Reply By: RMD - Sunday, Oct 28, 2018 at 07:33

Sunday, Oct 28, 2018 at 07:33
Kyle
I presume it is an RA model with a 4JJ1 engine.
Has the fuel filter really been changed?
Is there evidence the filter bowl was unscrewed to replace the filter?
When you say the fuel filters have been changed, it only has one, so no fuel filters plural.
Those engines often developed a faulty fuel pressure regulator, on rear of high pressure pump. That can be intermittent with fuel flow demand.
Seeing it happens more after fuelling up, a likely culprit may be the one way valve in the fuel neck cap is not allowing sufficient airflow into the tank to replace the fuel being delivered to the engine. That would be more evident after filling the tank but still constant depending on fuel demand. Run it without the cap and see if the problem goes away.
AnswerID: 621799

Follow Up By: King_Kyle - Sunday, Oct 28, 2018 at 10:22

Sunday, Oct 28, 2018 at 10:22
Thanks for your reply. I should have originally said it is the 4jh1 motor without common rail but has mechanical injection. And yes he definitely replaced fuel filter. I will try what you said and see if it works anyways worth a shot. Cheers kyle
0
FollowupID: 894421

Follow Up By: RMD - Sunday, Oct 28, 2018 at 10:50

Sunday, Oct 28, 2018 at 10:50
Sorry Kyle, I am unsure when the engine change to 4JJ1 happened, must have been a bit later.
0
FollowupID: 894423

Follow Up By: King_Kyle - Sunday, Oct 28, 2018 at 10:55

Sunday, Oct 28, 2018 at 10:55
All good mate, pretty sure it changed in 2007. Thanks for the advice I'll give it a go today
0
FollowupID: 894424

Follow Up By: King_Kyle - Sunday, Oct 28, 2018 at 23:10

Sunday, Oct 28, 2018 at 23:10
Thanks RMD ur an absolute legend gave the slowdeo a light thrashing today?? and ran like a dream with fuel cap off light didn't come on once. Looks like I'll be fixing that valve.
Thanks again mate
Kyle
3
FollowupID: 894455

Reply By: IvanTheTerrible - Sunday, Oct 28, 2018 at 10:17

Sunday, Oct 28, 2018 at 10:17
For god sakes. Take it to a mechanic and have it scanned with a proper scan tool
AnswerID: 621802

Follow Up By: King_Kyle - Sunday, Oct 28, 2018 at 10:27

Sunday, Oct 28, 2018 at 10:27
Hi Ivan thanks for replying. When you say proper scan tool what do you mean? I go to the mechanics on weekends and work on my other car and i bought the exact same tool he has which was used in a family Prado and worked perfectly erasing codes and stuff.
0
FollowupID: 894422

Follow Up By: IvanTheTerrible - Sunday, Oct 28, 2018 at 16:29

Sunday, Oct 28, 2018 at 16:29
Get it scan with a Gscan or siimilar machine which are designed to read all the codes and do a lot more. The SP scan is a toy and wont show all the codes on all the vehicles. Last trip out my engine light came on but didnt report a code on a similar basic scanner. It wasn't till I returned and put the G Scan on it did I discover it was a Universal Communication Error. You can ask the question on here and get a heap of misleading answers and waste your time if you want though.
0
FollowupID: 894436

Follow Up By: King_Kyle - Sunday, Oct 28, 2018 at 23:23

Sunday, Oct 28, 2018 at 23:23
Thanks for your time Ivan turns out RMD solved it so it wasn't a waste of time In the end. An just because I'm not a mechanic doesn't mean I don't know what I'm doing when it comes to cars so why would I waste money on mechanics guessing at what it could be when I can do it for free myself?
Each to their own I guess
4
FollowupID: 894458

Reply By: Mudripper - Sunday, Oct 28, 2018 at 13:20

Sunday, Oct 28, 2018 at 13:20
Hello Kyle,

Mine's a 2004 RA 4JH1-TC, so same engine as yours. The EVRV (electronic vacuum regulating valve) is the gadget that controls the EGR valve. The EGR valve is purely mechanical on these engines (no wires connected to it). I've experienced a couple of problems with the EGR valve over the last 10 years of ownership. Other than that it's been an extremely reliable vehicle. Now I will say that this isn't necessarily the problem you might have, but a possibility.

The EVRV is located right next to the air filter housing.

Regarding the EVRV, does yours have two vacuum hoses connected to it or three? The old version of the EVRV had a small, round filter underneath that can get blocked up over time. Usually the paper element falls apart when you try to clean it. An improved version came out, not sure of the year though, with an extra hose connected to the air filter box, that way the EVRV draws clean air all the time without blocking up. I modified mine in a way that exactly matches the improved version from the factory. If the EVRV is dodgy then the EGR valve won't open and close properly and the CEL (check engine light) will illumine and engine go into limp mode. Be aware that this problem can be intermittent and quite frustrating to pinpoint. So, just something for you to check if you haven't already.

Hopefully you'll get to the bottom of it and perhaps let us know what the problem was for future reference (and not just for my benefit lol).

Cheers, Tim.

AnswerID: 621807

Follow Up By: King_Kyle - Sunday, Oct 28, 2018 at 23:20

Sunday, Oct 28, 2018 at 23:20
Hey Tim thanks for the reply mate. I have the EVRV with three hoses, I thought that thing was called the VSV sorry. I took that off and cleaned it before wasn't to dirty.
In the end I think the problem was what RMD said with the one way valve on the fuel tank as I ran without the cap on and the light didn't come on at all.
Cheers kyle
0
FollowupID: 894457

Popular Content

Popular Products (14)