Electric Brake Controller Problem

Submitted: Tuesday, Aug 13, 2019 at 12:25
ThreadID: 138922 Views:6481 Replies:5 FollowUps:10
This Thread has been Archived
I have a Redarc Tow Pro installed on a 150 Prado. This was done by ARB in Dec 2014. It has worked well up until now. It goes into Limp mode on a random basis. Never whilst actually driving but only on start up WHILST the van is connected. This fault does not occur on every occasion. So it’s a bit of a pain after pulling over for a cuppa and on departure find the lights flashing on the brake controller.

If I start the car WITHOUT the van connected, then plug in the van, the problem does not occur. I have pulled apart both car and van connectors and checked wiring. All connections are clean and tight. Resistance on each contact, across the connected plugs, on a wire to wire basis is 0.1 Ohm.

I have not checked the wiring at the controller itself as is too hard for me to get at it under the dash and I don’t really know enough to try. Nor have I checked the wiring between the trailer plug and the electric brake unit either as it’s covered in bog that Kimberley seem to use everywhere. Covers all sins.

Redarc ( they have been very helpful) suggest that there may be a fault in the controller and to replace it with the latest Tow Pro Elite. Whilst that may be an option that I would be prepared to take it won’t help if the problem is in the the external wiring somewhere.

Your suggestions on a cause of the problem would be welcome. Alternatively a recommendation on a good auto electrician would also be useful.

I am in Perth southern suburbs.

Regards John
Back Expand Un-Read 0 Moderator

Reply By: 9900Eagle - Tuesday, Aug 13, 2019 at 14:40

Tuesday, Aug 13, 2019 at 14:40
John, try turning your 12v van fridge off and see if that allows the controller to fire up ok. It maybe a problem of voltage drop with the load of starting and the fridge.

I have had the same problem with a reverse camera that would only occur when firing up on cold mornings.To test the reverse camera I placed a switch in the feed to test it, once started I just turned the switch on and all was good.

So I guess if you can do a similar thing and find that is the problem, it would be a good idea to replace the controller.
AnswerID: 627222

Follow Up By: Member - J&A&KK - Tuesday, Aug 13, 2019 at 16:59

Tuesday, Aug 13, 2019 at 16:59
Many thanks for your response Eagle.

Something to think about and test. However I doubt that is the problem. The van has 300Ahr of lithium batteries installed that power the fridge and the brake actuator. The power leads to both devices are heavy gauge (rewired from the original cable). So I would think any voltage drop at start up would be minimal.

In addition the problem of the brake controller going into idle mode can occur after hours of highway driving when the caravan batteries would be fully charged.

The brake controller goes into idle mode the instant the car start button is depressed. In the Prado you have to have your foot on the brake prior to hitting the start button. So light on the controller is blue, put foot on brake and the light stays blue, hit the start button and even before the engine fires up the controller is flashing orange and is in idle mode.

As stated in the original post replacing the brake controller is an option and may prove to be more economical than employing a sparky to fault find the existing problem. However it could also be an expensive option if the fault continues.

I will give your idea a test and see how it goes.

Cheers John
FollowupID: 901200

Reply By: RMD - Tuesday, Aug 13, 2019 at 19:18

Tuesday, Aug 13, 2019 at 19:18
It seems to me the problem isn't starting but when the brake is pressed and brake signal goes to the van. If there is a loose wire or strand or there is a globe in the van which is not working as designed it may cause the problem . Sometimes globes flick a brake filament across to the taillight circuit. Not sure if you have globes or led lights. You may need to listen at all electric brake wheels to see if each magnet is applying. How old is the van? Is it possible a magnet is worn out and shorting to the hub to some degree, ie, too much load on controller and it has an error?
Can you connect to another van to check?
AnswerID: 627233

Follow Up By: Frank P (NSW) - Tuesday, Aug 13, 2019 at 19:52

Tuesday, Aug 13, 2019 at 19:52
I'm pretty sure John's van has electric over hydraulic brakes with a Carlisle actuator, so no magnets.

All the brake/sidelight/taillights are LED.

Not knocking, RMD, just eliminating possibilities.

Lifetime Member
My Profile  My Blog  My Position  Send Message

FollowupID: 901213

Follow Up By: Member - J&A&KK - Tuesday, Aug 13, 2019 at 21:11

Tuesday, Aug 13, 2019 at 21:11
Thank you RMD

Frank P is correct all LEDs and Disc brakes.

I will try connecting to a different van. If that solves the problem it will isolate the problem to the van side of the equation. Thanks for that advice.

Cheers John
FollowupID: 901215

Follow Up By: RMD - Tuesday, Aug 13, 2019 at 22:47

Tuesday, Aug 13, 2019 at 22:47
Frank P
Thanks for that, the reply was a bit generic and since you have said it is a different system the light has to be shone elsewhere. I haven't touched one of those so I must learn a new thing. I would still check all basic wiring integrity before delving into the $ bin.
If the system is usually reliable then it still appears to be Brake ON related with some component or connection. Nice for John to be advised by Redarc to buy a new one to see if it fixes it. Not much diagnosis there unfortunately.
FollowupID: 901220

Reply By: IvanTheTerrible - Tuesday, Aug 13, 2019 at 19:33

Tuesday, Aug 13, 2019 at 19:33
Redarc had a recall on a defective batch. You can check to see if your unit has been recalled on the redarc website
AnswerID: 627234

Follow Up By: Member - J&A&KK - Tuesday, Aug 13, 2019 at 21:16

Tuesday, Aug 13, 2019 at 21:16
Thanks Ivan

I didn’t know that. When talking to Redarc they did ask me for the serial number of the controller to which I stated I didn’t know. The S/N is on the unit under the dash somewhere. Not shown on the instruction manual that came with the unit - Sod’s law in play.

I will stick the camera under the dash and see if I can get some photos to find the S/N.

Cheers John
FollowupID: 901216

Follow Up By: Hoyks - Tuesday, Aug 13, 2019 at 21:51

Tuesday, Aug 13, 2019 at 21:51
I was thinking the recall too. Not so much a bad batch, but poor installations causing issues.

Here is the link to the recall notice:


"What are the defects?

Where the installation has not been carried out in accordance with the product manual, using dedicated wiring from a single battery supply, there is potential at any time for no trailer brake output indicated by a flashing yellow/red warning lamp."

FollowupID: 901218

Follow Up By: Member - J&A&KK - Tuesday, Aug 13, 2019 at 22:18

Tuesday, Aug 13, 2019 at 22:18
Thank you for the link Hoyks.

I followed the link. My unit was installed in Dec 2014 so it is a model prior to the Elite V2. However I will find the serial number and check with Redarc on any known problems with the particular unit.

The problem you highlighted on the installation may still be a problem. We have travelled some very rough roads in the last 4+ years so it is distinctly possibly that there is a poor connection somewhere in the vehicle.

I guess I will have to get the old body under the dash somehow and check the integrity of the connections. Not sure I want to pay the $80/hr recently quoted by a couple of local auto electricians. If I have to so be it.

Cheers John
FollowupID: 901219

Reply By: peteC - Tuesday, Aug 13, 2019 at 20:23

Tuesday, Aug 13, 2019 at 20:23
Try unplugging any usb charges in your car and see if it still does it.
AnswerID: 627235

Follow Up By: Member - J&A&KK - Tuesday, Aug 13, 2019 at 21:21

Tuesday, Aug 13, 2019 at 21:21
Thanks Pete.

I have tried that as I have had a “what the “ moment with the Prado once with the alarm beeping at me when it was shut down. Couldn’t work out what the problem was until I unplugged an android phone from a USB adaptor plugged into the rear power socket.

Cheers John
FollowupID: 901217

Reply By: nickb - Tuesday, Aug 13, 2019 at 23:22

Tuesday, Aug 13, 2019 at 23:22
The start battery may be on the way out. Double check the battery connections and get someone to load test the battery. You could try jump starting your car and see if the fault still happens.
AnswerID: 627241

Follow Up By: Member - J&A&KK - Wednesday, Aug 14, 2019 at 10:52

Wednesday, Aug 14, 2019 at 10:52
Thanks Nick.

That makes sense as the battery in the Prado is 4+ years old. From my experience start batteries have an average life of around 5years. This is the first Toyota I have owned so I don’t know what life to expect from a Toyota OEM battery.

One more thing to test.

Cheers John
FollowupID: 901223

Follow Up By: Ron N - Thursday, Aug 15, 2019 at 13:03

Thursday, Aug 15, 2019 at 13:03
I got 4 years and 4 months out of the OEM battery in my diesel 2013 Hilux.

It was still starting O.K., every day, all day long - but if I allowed any current draw (even relatively low current draw) to happen over a couple of hours - such as leaving the door open, and the interior light on - the battery would refuse to crank the Hilux at normal speed. It just wouldn't start it.

The final kick came the morning in early July 2017, right as I was loading up to drive to Broome from Perth.
I left the drivers door open for an hour, while I loaded up, and the Hilux wouldn't start.

I went and purchased a new battery, and put the old one aside, and went to Broome for my Winter break.

When I came back from Broome, I set the old battery up on my 4 amp trickle charger, with my Infinitum battery desulfator. I left it on charge for a couple of days.

When I'd finished charging it, I installed the battery in my Toyota 4 cyl diesel forklift.
It worked just fine! - and it's still working just fine, a full 2 years later! It will still start the forklift, no problem, on cold mornings.

This battery is a bog-standard lead acid battery with screw-on tops. Just goes to show that sulfation is always major problem with L-A batteries and it can often be reversed with a desulfator.

Cheers, Ron.
FollowupID: 901250

Sponsored Links