80 series electrical problem.

Submitted: Saturday, Mar 05, 2005 at 16:11
ThreadID: 20974 Views:1795 Replies:3 FollowUps:0
This Thread has been Archived
Hi guys,
I was coming back from a trip today, with camper in tow, when I hit a bump in the road causing both the fuel gauge & the temperature gauge needles to rise to their maximum possible position. This has happened to me once before, again while I was towing, both times I pulled over & checked the engine temp just in case it was over-heating, & found it to be operating normally. So I'm wondering if anybody has had similar problems & how they fixed the problem.
Thanks, OM&M.
Back Expand Un-Read 0 Moderator

Reply By: Patroleum - Saturday, Mar 05, 2005 at 21:25

Saturday, Mar 05, 2005 at 21:25
I had the same fault with a 70 series l,cruiser Bundera. Used to happen on highway driving only, both fuel and temp would go to full at same time. Spoke to instrument tech in Brisbane - he said it was a faulty voltage regulator in the instrument cluster. Never had it repaired but from memory it was not very costly.

Good Luck

Greg
AnswerID: 101253

Reply By: jenkie - Saturday, Mar 05, 2005 at 22:37

Saturday, Mar 05, 2005 at 22:37
As said above it could be the voltage regulator but could be the earth to the voltage regulator causing the problem
Jenkie

Member
My Profile  Send Message

AnswerID: 101269

Reply By: Of Mice & Men - Sunday, Mar 06, 2005 at 08:46

Sunday, Mar 06, 2005 at 08:46
thanks guys,
I will look into getting it fixed, thanks for the info. I realize I could leave it, but every time it happens, it scares the s**t out of me.

all the best OM&M.
AnswerID: 101289

Sponsored Links

Popular Products (14)