Installing Delphi fuel filter on 12HT Landcruiser

Submitted: Monday, Jun 13, 2005 at 11:26
ThreadID: 23818 Views:7473 Replies:6 FollowUps:0
This Thread has been Archived
Hi,

I've bought a Lucas/CAV/Delphi fuel filter with the water trap to instal as a second filter on my Landcruiser.

I'm having trouble getting the lift pump to suck the fuel through the filter, even after the new filter is fully primed with fuel. I've mounted the filter just under the air filter so it requires the fuel to rise about 200mm to the filter before going back down to the lift pump. However even after I lower the filter it still won't suck through.

Nothing seems to be blocked as I can blow air through with my mouth - great taste too!

Does anyone have any experience with installing these? Do I need to instal it under the vehicle - which I'm reluctant to do as it's likely to get damaged. I'm wondering how strong the lift pump is on suction normally and whether I might have discovered a problem with the pump that I didn't know I had.

Thanks
Tim
Back Expand Un-Read 0 Moderator

Reply By: squiz - Monday, Jun 13, 2005 at 15:01

Monday, Jun 13, 2005 at 15:01
I have just installed the same filter in my patrol.
Found the pump in the filter had plenty of draw.
A lot better then the original filter pump.
Anyway my guess would be maybe you have the in and output
the wrong way around. It wasn't clearly marked.
Good luck , my new filter works well.
AnswerID: 115540

Reply By: Member - Geoff M (Newcastle) - Monday, Jun 13, 2005 at 15:45

Monday, Jun 13, 2005 at 15:45
Hello Tim,
Don't happen to have an air leak do you?
No matter how powerful the lift pump, if air is entering the system it won't pump fuel.
I've installed this filter on my old 2H diesel and it worked fine. Wouldn't prime until I did fix the air leak though.

Geoff.
Geoff,
Landcruiser HDJ78,
Grey hair is hereditary, you get it from children. Baldness is caused by watching the Wallabies.

Lifetime Member
My Profile  My Blog  Send Message

AnswerID: 115546

Reply By: jon p qld - Monday, Jun 13, 2005 at 21:00

Monday, Jun 13, 2005 at 21:00
G'day Tim
I installed the same unit on a 1HZ LC and had the same problems as you. checked and double checked for air leaks. Also had problems bleeding air out of the system, engine would run fine until left for a few days then air was somehow getting back into the system making it hard to start. Unfortunately I'm not much help to you as I got fed up with tinkering with it and pulled it off in the end. However if you work out where the problem is let us know, as my unit is still sitting in the garage and I may have another go at it.

Thanks Jon
AnswerID: 115592

Reply By: Peter 2 - Monday, Jun 13, 2005 at 21:36

Monday, Jun 13, 2005 at 21:36
I've run one on a 2H for years between the sedimenter and the lift pump with no problems
I've also run one on a 1hz in addition to the tojo filter with no problems.
I've had the air leak problem with one on an old landy and it took us days to find the leak.
what we did to find it was to fill it with fuel, then connect an airhose with about 10 psi to the inlet and then we found the bubbles of diesel under one of the unions, end of problem with new copper washers.
I plumbed it in the reverse direction as shown on the cast top (an old diesel mechanic told me) so that the fuel goes into the bowl first, then through the filter. If you plumb it according to the arrows on the CAV ones it goes into the filter first and then all the muck is in the filter rather than the glass bowl. Some other brands are arrowed correctly.
I's reckon that a 12HT/2H would have no problem pulling fuel through the extra filter if there were no air leaks and the lift pump was ok. Check the gauze filter on the inlet to the lift pump as they sometimes block up causing problems.
Peter
1996 Oka Motorhome

Member
My Profile  My Position  Send Message

AnswerID: 115610

Reply By: Member - 'Lucy' - Monday, Jun 13, 2005 at 21:42

Monday, Jun 13, 2005 at 21:42
Evening Tim

I removed the two fuel filter units on my 1997 75 series and replaced them with the CAV water/crap seperator unit and the CAV filter unit with the little pump on top.

The change over went like a dream.

Trying to prime that mother was the greatest bitch of all time.

Took me two days to work out the problem.

A seal was missing in the water/crap seperator unit.

It is a big one that fits in between the head of the unit and the cast round 'barrel' between the head of the unit and the glass inspection bowl.

Its something you can't see until you pull the whole thing a part.

Replaced that seal and it primed easy as, and the lift pump took it from there.

It rises from the chassis rail up to about the bonnet level, through both filter units and down to the lift pump on the other side of the engine.

So my recommendation is to pull that whole CAV unit apart and ensure that ALL of the seals have been provided and are in place, as the tiniest bit of air leakage kills the whole setup.

Regards

Ken Robinson
AnswerID: 115611

Reply By: Tim HJ61 (WA) - Saturday, Jun 18, 2005 at 19:29

Saturday, Jun 18, 2005 at 19:29
Thanks for everyone's response.

Unit installed, primed, and works.

I 'may' have had an air leak but doubt it - although I did pull it all apart again and make extra sure.

Main trick seems to be priming it with the hand pump until there was a clean flow of fuel coming from the main bleed valve on the main filter. I'd previously tried to fill the filter with fuel and then start the engine, but that didn't work. An injection mechanic suggested I prime it manually, which seems to have done the trick.

Tim
AnswerID: 116271

Sponsored Links

Popular Products (14)