Harmonic balancer on 80 Series

Submitted: Saturday, Oct 11, 2003 at 20:53
ThreadID: 7743 Views:1136 Replies:2 FollowUps:0
This Thread has been Archived
A mate of mine has a 80 SeriesT/D crusier and cannot keep the harmonic balancer tight on the crank.The first time it slogged out the keyway(the bolt was tight)and stuffed the H.B.After fitting a new H.B and bearing mounting everything in place it only lasted about three months.This time he removed the crank,had it built up and a new keyway cut,mounted everything up again and what do you know 5 months later it working loose again.Is this a common problem?What are people doing to get over this(dont say buy a Nissan either)?
Back Expand Un-Read 0 Moderator

Reply By: Dave ....Adelaide - Sunday, Oct 12, 2003 at 02:28

Sunday, Oct 12, 2003 at 02:28
gidday Nick
I had the same problem on a Mazda ute once ......done it up nice and tight with some locktite , no more probs .....hope this helps
Regards DAVE
AnswerID: 33456

Reply By: Member - Eric- Sunday, Oct 12, 2003 at 20:39

Sunday, Oct 12, 2003 at 20:39
come across this problem on a manuel valiant many years ago , it ended up been a missing counter weight on the flywheel that caused a vibration down the crank . also Whilst ypur there , better check your end float , if the bolt was tight and you used lock tight , then you have a problem elsewhere , make sure that all that is connected to the same fan belt is running true .Venus Bay
AnswerID: 33510

Sponsored Links

Popular Products (13)