Problem with HWS

Submitted: Friday, Apr 23, 2010 at 16:19
ThreadID: 77954 Views:2710 Replies:1 FollowUps:1
This Thread has been Archived

Related Pages

Hoping someone may know the answer. We have an 05 Olympic caravan and we are trying to use the hws on gas (worked perfectly on 240v) but just isn't happening now. Its a suburban and we have 12v power to switch, thermostat and board but still no hot water and no light at switch. Any ideas??? Yes he checked the gas.
Back Expand Un-Read 0 Moderator

Reply By: MEMBER - Darian, SA - Friday, Apr 23, 2010 at 18:18

Friday, Apr 23, 2010 at 18:18
I use one to, but it's not quite 12 months old. At 5 years, yours may well need a pro service (or..... shudder..... possible replacement). I didn't get a manual from our van builder for ours, so requested one from this mob [ Suburban Heater agent ]- it was forwarded promptly, in PDF form. The only time mine wouldn't go was when I forgot to turn on the gas supply isolating valve under the dinette. BTW - keep a check on the anode - surprising how fast that metal is lost. This heater start up issue was queried on one of the Caravan forums recently too - helpful advice as I recall.
AnswerID: 414056

Follow Up By: Ed & Bern - Friday, Apr 23, 2010 at 21:21

Friday, Apr 23, 2010 at 21:21
Thanks Darian, we found the heater agent great as well, emailed us the wiring diagram with what to check and in what order. Did all this before our post. Hubby decided that it must be the board so off to the repair centre he went and $225 later we have hot water but still no light in the switch.
We will keep an eye on the anode - have noticed a number of members have mentioned this in previous threads.
FollowupID: 684298

Sponsored Links

Popular Products (11)