Lap Top Probs.

Submitted: Wednesday, Nov 19, 2003 at 10:24
ThreadID: 8619 Views:1593 Replies:7 FollowUps:6
This Thread has been Archived
Hi All,
I have a prob with my lap top, each time I plug my GPS into the com port it fails to recognise the unit. The only way I can get it to recognise the unit is to uninstall the com port then re-boot the computer and it auto installs the com port and recognises the GPS.Which is a bit of a pain. Is there some way I can overcome this prob so that one can just plug the GPS in and bobs your uncle?
Any suggestions please.
RegardsDodg
Back Expand Un-Read 0 Moderator

Reply By: ogray - Wednesday, Nov 19, 2003 at 10:39

Wednesday, Nov 19, 2003 at 10:39
Hi Dodg,

I beleive that this is the only way that you are going to be able to get the system to recognise the GPS. COM ports, unlike USB ports, will not recognise you plugging anything into them untill a reboot of the system has been done, which is when they are intialised. Also as an added precaution I would not connect or disconnect anything to the COM Port whilst the system is running as this can cause a power spike which may burn out components either in your GPS or system hardware.

Owen
AnswerID: 37787

Reply By: Member - Sam (NSW) - Wednesday, Nov 19, 2003 at 10:46

Wednesday, Nov 19, 2003 at 10:46
Roger

what are the specs of the system? (is it a winxp machine). I am able to plug my GPS into the COM port at any stage on my laptop running XP Pro and it will work fine. What model GPS and GPS/mapping software are you running?

cheers,
Sam.
AnswerID: 37789

Follow Up By: Member - Raymond - Wednesday, Nov 19, 2003 at 11:04

Wednesday, Nov 19, 2003 at 11:04
Hi Roger
The laptop running XP has no problems with the GPS, but the desktop with windows ME and the old Laptop with windows 98 both had difficulty recognizing the GPS unless they were rebooted.
Raywanderin' in retirement. victor 2010
0
FollowupID: 27391

Follow Up By: Member - Sam (NSW) - Wednesday, Nov 19, 2003 at 12:00

Wednesday, Nov 19, 2003 at 12:00
I think Ray is spot on. XP will poll the ports periodically, looking for new devices, where as any of the win9x (inc winme) don't or at least don't do it as nicely (plug and play with win9x based machines is more of a plug and pray thing), hence requiring a reboot, making sure the device is first connected. You shouldn't have to re-install the com port. There isn't another device/software trying to use that com port is there? Like an internal modem or fax software? Just that Com 1 and 3 usually by default share the same IRQ and 2 and 4 share the same one.
0
FollowupID: 27403

Follow Up By: Foss - Wednesday, Nov 19, 2003 at 18:53

Wednesday, Nov 19, 2003 at 18:53
The thing is folks that the OS does nothing with the serial port with regard to the GPS so it don't matter a toss what it's doing with the port other than it's not being enabled/configured correctly or in use by the OS itself.

Win 98 and older MS OS have a "feature" that drops the interupt request for a serial port if it's found not to be active at boot.This particularly affects laptops with internal mouse/pointer/touchpads as they don't utilise serial ports unless a modem is attached. MS did this as a feature to speed up the OS from '95A onwards to '98 OSR2.5 (less interupts to scan more time to process). You can add a line in system.ini/cfg? to force the port/s active but it's been so long since I worked on either of these that I can't remember what it is. Rogers' problem extends from the "no active ports at boot time issue", if he is using an older generation MS OS. If the GPS is connected to the serial port and switched on at boot time the machine should activate the interupt and the mapping software will be able to see the port.

The OS will not recognise a GPS. Plug and play works via bios interogation/signature recognition. I don't think any GPS comes equiped with a plug & play bios as yet and even if it did what use would it be without the third party software.

Anyway, having crapped on about all that, Roger still needs to answer a few questions about his setup to make this any more than conjecture really.

Foss.
Bill Gates has a lot to answer for.
0
FollowupID: 27441

Reply By: Foss - Wednesday, Nov 19, 2003 at 12:01

Wednesday, Nov 19, 2003 at 12:01
G'Day Roger

If you are using third party software with your GPS, and you most likely will be, the serial port interupt will be hooked by code in that application when it loads. There are so many possibilities that covering them all here would be extremely long winded. Just a few, mouse driver conflict, OS not relinquishing interupt, port incorrectly configured, multiple ports with same config. it goes on and on.

Before you do anything else you need to establish whether or not the serial port is working correctly with your OS. You can use Hyperterminal to sus that out if you are using windows. Plug in a modem, connect it to your serial port and switch it on. run up hyperterminal and make a DIRECT connection with the serial port. when you have, type ATZ and press enter. you should get some sort of affirmative response like "OK" or maybe just a new line and carriage return depending on your equipment. If that works out do this.

tell us,
1. what opertating system you are using.
2. what software you use with your GPS.
3. what you were doing before you ran up your GPS software.
ie, from a clean boot, running web connection, ETC.

By the way. If the port is not in use you can plug and unplug to your hearts content. By that I mean if there is no software running that has the serial port active.

Cheers
Foss
AnswerID: 37795

Reply By: Boobook - Wednesday, Nov 19, 2003 at 13:20

Wednesday, Nov 19, 2003 at 13:20
My PC doesn't have a serial port unless it is in the docking station so I bought a USB to serial converter for the GPS ( and other things).

It was about $50 from Dick smith from memory.

If you don't get joy from your native serial port this may be a solution.

Boobook.Boobook
AnswerID: 37801

Reply By: Member -BJ (Sydney) - Wednesday, Nov 19, 2003 at 15:19

Wednesday, Nov 19, 2003 at 15:19
Had the same problem with ours turn laptop on first with gps pluged in then turn on gps if i did it the other way laptop would read port.Regards Bob
Where to next
AnswerID: 37820

Reply By: KG - Wednesday, Nov 19, 2003 at 21:33

Wednesday, Nov 19, 2003 at 21:33
reason number 44329039 why serial should hurry up and die!
vote 1 USB!

:)

cheers,

KG
AnswerID: 37859

Reply By: Member - Roger - Thursday, Nov 20, 2003 at 14:48

Thursday, Nov 20, 2003 at 14:48
Thanks all,
I have tried starting up with the GPS plugged in and off also plugged in and on but no go the only way it will connect is if I uninstall the com port then reboot with the GPS plugged in.
I am driving an IBM ThinkPad with pentium three, 128meg ram and a 12gig h/drive on windows 2000 professional with the latest OzieExplorer mapping software.
Sorry Foss I do not quite comprehend your info.
Maybe I should try Boobooks suggestion IE. try a usb to serial converter, I just don't know.
RegardsDodg
AnswerID: 37927

Follow Up By: Foss - Thursday, Nov 20, 2003 at 20:17

Thursday, Nov 20, 2003 at 20:17
G'Day Roger

Maybe a good idea. Stinkpads have problems all of there own and thats all i'll say about that. you could be here for a very long time trying to sort it out.

Good luck with the convertor. It should solve your problems.
cheers.

0
FollowupID: 27533

Follow Up By: Member - Roger - Friday, Nov 21, 2003 at 13:23

Friday, Nov 21, 2003 at 13:23
I should also have mentioned that the GPS is a Garmin 12XL.Dodg
0
FollowupID: 27588

Follow Up By: Foss - Friday, Nov 21, 2003 at 16:14

Friday, Nov 21, 2003 at 16:14
I guess I should tell you that I have a very similar setup. Ozi + Notebook + 12XL. Works great.

Depending on how much you want to get the GPS working with serial connection, you might want to download the driver set for your notebook from IBM and load it. There will be a few and it might take a while but all the things that go wrong now with it will probably stop going wrong. We had hundreds on thinkpads where I worked, supporting them was a nightmare. We ended up getting rid of them and using Toshiba.

With Thinkpads it's all about the right drivers for the OS you are running. Good luck with your setup.

Foss
0
FollowupID: 27603

Sponsored Links

Popular Products (13)