Ozi Issie with Tracks on Maps

Submitted: Wednesday, Apr 04, 2012 at 09:51
ThreadID: 93001 Views:1748 Replies:4 FollowUps:15
This Thread has been Archived
Hi All (can you help with this one Greg)

I have been using Ozi now for year and it is a tool that I never leave home without. I always update to the latest version when they become available but have encountered a Bug with the new upgrade and I was wondering if anyone else has had the same issue??

It does not matter if it is either tracks directly onto a map via moving maps or tracks imported from my GPS, I save the required track or tracks as I have done so for years now and close Ozi. The next time that I open Ozi, all the tracks that have been on the maps are there again, and I have tried everything possible to remove the tracks but with no success.

I have removed all mm track files, cleared all tracks from maps but they do not go. The only way that I can get a clean map again is to install an older update from November 2011, and then it works the way that it should, no track files when I open it up again.

Am I alone with this issue or have others encountered it. I have sent an email to Des, and he said to "Moving map Menu / Clear Track tail and this does not get rid of the track on the map.

I would like to hear from the wider Ozi users out there to see if it is just me or are the gremlins at work.




Cheers



Stephen
Simpson Desert Colours

Lifetime Member
My Profile  My Blog  My Position  Send Message

Back Expand Un-Read 0 Moderator

Reply By: The Explorer - Wednesday, Apr 04, 2012 at 11:35

Wednesday, Apr 04, 2012 at 11:35
Hi

Could be a bug but as the latest version has been out for a while (Nov '11) and I have never seen or heard of the "issue" before supsect it is a setting somewhere - tracks can be made to load automatically by a number of methods...

I suspect, base on the fact that the issue doesnt arise when you use an older version of OziExplorer that maybe you have been fiddling with the Project Manager option (relatively new feature). Could be wrong but with Oziexplorer open (latest version) click on the Options menu along the top of the screen then select Project Manager - make sure you dont have "Auto Load this Project" box ticked.

The other way to add tracks to a map file so they auto open is to use File -> Check Calibration of Map ....then select Options under the Setup tab - here you can select files (waypoint, tracks, routes) to "attach" to the map every time it opens.....so check this as well though this is unlikely to be the problem as it would result in the same issue with older versions.

Well thats all I can think of at the moment..let us know if solution found or if more research needed.

Cheers
Greg
I sent one final shout after him to stick to the track, to which he replied “All right,” That was the last ever seen of Gibson - E Giles 23 April 1874

Lifetime Member
My Profile  My Blog  My Position  Send Message
Moderator

AnswerID: 482303

Follow Up By: The Explorer - Wednesday, Apr 04, 2012 at 12:07

Wednesday, Apr 04, 2012 at 12:07
...just to clarify if Project Manager is the issue you would first have had to create a Project and then added tracks. Not sure how this would have happened without your knowledge but maybe you were messing around late one night and didnt realise consequences.

Cheers
Greg
I sent one final shout after him to stick to the track, to which he replied “All right,” That was the last ever seen of Gibson - E Giles 23 April 1874

Lifetime Member
My Profile  My Blog  My Position  Send Message
Moderator

0
FollowupID: 757544

Follow Up By: Member - Stephen L (Clare SA) - Wednesday, Apr 04, 2012 at 20:07

Wednesday, Apr 04, 2012 at 20:07
Hi Greg

This seems a very strange little "bug". The small Netbook that I use in the car is for car use only and I have done nothing different than I have done in the past:-

Start recording with the Moving Maps icon, then at the end of the day, stop moving maps, "Save Track" to my file where I want to save the days Track to, then close Ozi.

When I did this last Saturday it all worked as usual, but when I opened it up on Sunday, the full days previous Track was visible on the Map, which I have never had this happen before.

I then spent a lot of time. removing the mm Track file, so in fact there should have been no track to pick up as such, yet the track was still showing on my Natmap.

I then loaded the previous version of Ozi updates, reloaded the mm Track file back into the Ozi folder, opened Ozi and it worked a treat, no Track file. I then reloaded the new version, removed the mm Track file, reopened Ozi and the bloody track magicly appeared again.

I then repeat the above again, but this time I stayed with the previous version and no more issues......very strange.



Thanks for your reply.




Cheers



Stephen
Simpson Desert Colours

Lifetime Member
My Profile  My Blog  My Position  Send Message

0
FollowupID: 757572

Follow Up By: The Explorer - Wednesday, Apr 04, 2012 at 20:12

Wednesday, Apr 04, 2012 at 20:12
No worries - sorry didnt realise it was closely related to your use of Moving Map which I havent really used since about 2000 when I discovered OziCE and PDAs and tossed the laptop into the back of the car:)

Cheers
Greg
I sent one final shout after him to stick to the track, to which he replied “All right,” That was the last ever seen of Gibson - E Giles 23 April 1874

Lifetime Member
My Profile  My Blog  My Position  Send Message
Moderator

0
FollowupID: 757573

Reply By: Member - Fred B (NT) - Wednesday, Apr 04, 2012 at 14:07

Wednesday, Apr 04, 2012 at 14:07
Hi Stephen,

Ozi Users Group is always a good place to get info.
regards
Fred B
VKS 737: Mobile/Selcall 1334

Lifetime Member
My Profile  My Blog  My Position  Send Message

AnswerID: 482314

Follow Up By: Member - Stephen L (Clare SA) - Wednesday, Apr 04, 2012 at 19:54

Wednesday, Apr 04, 2012 at 19:54
Hi Fred

Thanks for that. It still seems a very strange issue, as I have been using Ozi now since 2004 and I have never had this happen before.

I will stick with the previous update, as I know that I had no issues.


Cheers



Stephen
Simpson Desert Colours

Lifetime Member
My Profile  My Blog  My Position  Send Message

0
FollowupID: 757570

Reply By: ROODOO2 - Wednesday, Apr 04, 2012 at 15:25

Wednesday, Apr 04, 2012 at 15:25
G'day Stephen
I noticed that mine also shows recent moving map trail (only since newest version).
Seeing that each day is saved as a separate mm file I do not think it was a problem.
Perhaps if you were to go for a short mm drive today and then tomorrow check if old trail is added to todays mm file, you will need to wait until after midnight as that is when ozi saves the days file , as I understand it.
Hope this simplifies rather than confuses .
MIKE
AnswerID: 482320

Follow Up By: The Explorer - Wednesday, Apr 04, 2012 at 19:43

Wednesday, Apr 04, 2012 at 19:43
"Seeing that each day is saved as a separate mm file I do not think it was a problem. "

Hi - you can set the track log file using configuration to save: never, daily, weekly or monthly...so daily may not be an issue but weekly or monthly could mount up !!

Cheers
Greg

PS: I dont use MM on PC version so my suggestion above about Project Manager could be way off track (pun intended:)...maybe something to do with track log file save interval?
I sent one final shout after him to stick to the track, to which he replied “All right,” That was the last ever seen of Gibson - E Giles 23 April 1874

Lifetime Member
My Profile  My Blog  My Position  Send Message
Moderator

0
FollowupID: 757566

Follow Up By: Member - Stephen L (Clare SA) - Wednesday, Apr 04, 2012 at 19:51

Wednesday, Apr 04, 2012 at 19:51
Hi Mike

At least that I am not alone. The mm Track will record a track continuous in your Ozi Folder, but I always keep a separate days track when we travel. I will reload the older version, as I have no issues with that.

I have never ever had a previous days Track file open the next time that I open Ozi, so it seems very odd.


Thanks for your reply.



Cheers


Stephen
Simpson Desert Colours

Lifetime Member
My Profile  My Blog  My Position  Send Message

0
FollowupID: 757568

Follow Up By: shark_caver - Wednesday, Apr 04, 2012 at 21:01

Wednesday, Apr 04, 2012 at 21:01
The last ozi update had a few changes. The track is now not stored by default to track 1 as it has been forever. To me this is a bit of a pain as I usually save my track and export to a gpx file for transfer between different applications. To save the track you can either select "log track to file" or "copy track tail to track 1", both found in the moving map tab. This had me stumped for a bit. I discovered this after reviewing the ozi version change log. To delete the on screen track, you need to select "clear track tail" (make sure you have saved it first if you wish to keep it, unlike what I did). In the help file, have a good read of moving map. Everything is explained in there.
0
FollowupID: 757581

Follow Up By: ROODOO2 - Wednesday, Apr 04, 2012 at 21:29

Wednesday, Apr 04, 2012 at 21:29
Yes Stephen
It is most disconcerting when a plot I am not expecting pops up. I just cleared my last trip as DES said to you" MOVING MAP /CLEAR TRACK TAIL"
As Greg noted in follow up 1 , in latest version you have option to set MM to save "never / daily / weekly / monthly " set this in configuration/ track / save track / daily / save . I just note date of trip or for more interesting tracks rename by replacing " moving map " (in file name ) with something meaningful. I have just tried my netbook (bush PC ) and all moving map files are only the one day.
All the best MIKE
0
FollowupID: 757584

Follow Up By: Member - Stephen L (Clare SA) - Wednesday, Apr 04, 2012 at 21:30

Wednesday, Apr 04, 2012 at 21:30
Hi Shark_caver

I do not think that this is the issue. Like I have said, I have been using Ozi now for a very long time and I have alway used the "Log Track to File" and I have it set up on a daily basis.

In this way when I go on a trip, I open the Oziexplorer Folder, and right down the bottom, you will see an "mm File". In this file, my complete holiday track file will be shown in one complete file. If you never clear this file, you could have years worth of track file stored without ever knowing that it existed. There is a simple way to clear this file, which in the Moving Map tab is "Clear Track Tail" just as you have stated.

Every day when I travel, I always save my days "Moving Track" to a seperate file in another folder, giving me a Track file for every day, as well as a complete continious mm Track file. At the end of the day after saving the Track file and making sure that I have a copy, I then close Ozi.

The next day or time when I open Ozi, I start the whole prosess again, but now, the previous track files are still shown on the Map and this has never ever happened to me before with Ozi.

Thanks for your reply.


Cheers


Stephen
Simpson Desert Colours

Lifetime Member
My Profile  My Blog  My Position  Send Message

0
FollowupID: 757585

Follow Up By: shark_caver - Wednesday, Apr 04, 2012 at 22:01

Wednesday, Apr 04, 2012 at 22:01
Hi Stephen, I get a better picture of what your doing from your last post. So you are autosaving your tracklog (mm file) and saving your daily file as well. What I found from the new update (nov 11 IIRC) is that to save a daily track file, at shutdown you need to select "copy track to track 1" then save as usual. You didnt need to copy to track 1 in previous versions, the track was automatically assigned to track 1, so there is an extra step needed to be performed since the update.

When you reboot the PC the following day, before you start off, you need to click "clear track tail" to remove the autosaved MM file from plotting the old track on the map. Well this worked for me anyway but I'm not using autosave (log track to file) . If the autosaved track is still showing on yours after clearing the tail, then off the top of my head I cant answer that, except to direct you to the moving map help file, its very comprehensive. As I don't use the autosave function of ozi, I wonder if this is the difference between us?? All I can do is direct you to the help file:moving map. Its all buried in there, your challenge is to find it. I also sent ozi help an email on clearing the old track off the map, they responded within a couple of days and were helpful. I didn't keep that email unfortunately, but I'm sure all they told me was to clear the track tail.
0
FollowupID: 757587

Follow Up By: shark_caver - Wednesday, Apr 04, 2012 at 22:11

Wednesday, Apr 04, 2012 at 22:11
footnote: I'm using V3.95.5m. Looking at the ozi site this isn't the current version. Version m was August 2011.

I see nothing in the change log for version n (Nov11) but below is the moving map changes for version m

The Track Tail (track collected for viewing on screen as you move) is now a buffer of 10000 track points.

The last 10000 track points are automatically saved and loaded.
The track tail is no longer logged into track 1.
The Track Tail defaults are on the Track tab in Configuration.
The are options for the Track Tail on the Moving map menu.
A smart algorithm based on changed distance and heading is used to log points.

Track logging to File is now enhanced.

You can specify Daily Files, Weekly Files, Monthly Files or "Never change the file" (the previous version method).
The default is a Daily Log file - this means for each day of travelling a new track file is automatically created.
The Track Log File default is on the Track tab in Configuration.
There are options for the Log Track to File on the Moving map menu.

The number of user loaded tracks has been increased to 1000 (from 75).
When a Track is loaded it is automatically inserted into the next free track (not track 1), previous versions always loaded a single track into track 1.
A new property for Line Style has been added for tracks.
0
FollowupID: 757589

Follow Up By: Black Cobra (WA) - Wednesday, Apr 04, 2012 at 23:26

Wednesday, Apr 04, 2012 at 23:26
G'Day Stephen,

And I thought you were the guru. I have the same problem with the track coming up the last time I used Ozi and wondered what was going on and then your post came up.

Mucked around a bit and this is what I did and which has been previously expalined but I managed to remove the tracks from the maps everytime I opened the map up. I to save tracks every day the same way you do and I think this track tail is something new in the update, anyway my steps were:-

Select "File"
Select "Load Track from file"
Select "load track from file (multi)
Should bring up Tracks Folder with all your saved tracks
Click down arrow and select "Data" folder
You should see all the tracks that are saved listed as Tracking with the date/dailyplt
Highlight and delete all these tracks if you don't want them as you probably have saved them as you usually do

Then click on Moving Map tab and you will see a tick possibly alongside "Log Track Tail" and " Log Track to File"
Click clear Track File and tracks will be deleted

To find Track Tail click "File"
Select "Configuration"
Select "Track" tab
and you will see on the right Track Tail Defaults click box where it states Daily" and I think if you select "Never" it might not save the tracks when you turn of Ozi

I did the above and now when I start up Ozi again the tracks are not brought up on the maps as before.

I have not changed from "Daily to Never" as of yet until I use Ozi again and might try and take the tick off "Log Track Tail" and see what happens.

Anyway see if that works but I am not saying its the answer, fly out tomorow so good luck.

Cheers
Stewart
0
FollowupID: 757590

Follow Up By: Member - Stephen L (Clare SA) - Thursday, Apr 05, 2012 at 08:04

Thursday, Apr 05, 2012 at 08:04
Hi shark_caver and Stewart

I will reload the new updates again and follow your advise and see how I go.

Re the "Log Track Tail"

I know from the past that if that is not ticked, you do not get a continuous mm Track file. There can be some people that this would not matter, but like I have said above, it gives me a full Track log for a complete trip, and if for some strange reason I do not save a section of daily Track, I know that I am covered with the full mm Track file.

Thanks for these great tips.





Cheers


Stephen



ps:Have you thought any more about what I spoke to you about Stewart??? and I hope you are travelling well after your time off of work.
Simpson Desert Colours

Lifetime Member
My Profile  My Blog  My Position  Send Message

0
FollowupID: 757603

Reply By: Member - Chris & Debbie (QLD) - Sunday, Apr 08, 2012 at 13:15

Sunday, Apr 08, 2012 at 13:15
Hi Stephen,

How did you go, get it sorted? I have been sitting at work bored so have been re-creating you problem with the MM simulator, I will try to explain what I have found, pretty long winded but may help.

In the new version, 'Log Track to File' and 'Long Track Tail' are two different things. if you tick 'Log Track to File' it does as is alway has, and records your track to the Data folder in Ozi. How it is recorded depends on whether you have selected 'Daily', 'Weekly', 'Monthly' or 'Never' in the Track Configuration. Selecting 'Never' will create a never ending MM.plt as in the older versions, selecting this also adds the 'Change Track Log File' to the Moving Map Menu.

Selecting 'Daily, Weekly, Monthly' removes the 'Change Track Log File' from the Moving Map Menu. Instead it will save the track log with the date and type (e.g TrackLog 2012-04-08 daily) in the normal Ozi Data folder.

As you found, if 'Log Track Tail' is not selected you will not get a track line drawn on the screen, but as long as 'Log Track to File' is tick the track will still be saved. Having 'Log Track Tail' ticked will show you track on the map and will be there each time you start Ozi, which will show the previous days trails of your trip. If you do not want to see the previous track trails just click on 'Clear Track Tail' under the Moving Map Menu.

The 'Track Tail' is not automatically saved and will be deleted when you clear the track tail. You have to 'Copy Track Tail to Track 1' if you need to save it.

The way I use it is to set 'Track Log File' to 'Daily' in the Track Configuration, tick both 'Log Track Tail' and 'Log Track to File' in the MM menu. I prefer to leave the track tail on the map for the entire trip. Setting Ozi this way you get a new track log daily automatically saved and at the end trip you can 'Copy Track Tail to Track 1' so you also end up with a single track log as well as the daily logs that were auto saved. (either that or just load and join all the daily log files'.

Hope you had a good easter.
Chris
AussieHF touring club. 1089
-------------------------------------------

Member
My Profile  My Blog  My Position  Send Message

AnswerID: 482515

Follow Up By: Member - Stephen L (Clare SA) - Sunday, Apr 08, 2012 at 20:25

Sunday, Apr 08, 2012 at 20:25
Hi Chris

Thanks for taking the time to have a play with Ozi and giving me that great reply. I have had to go back to the older update, as I had another problem with the new update with the Moving Map Track file.

The Only thing that I did not do as you suggested, was to "Copy Track Trail to Track 1"

With the Track Trail on my map, I did what I usually do, stop communications with GPS (in my case I use a GPS mouse) and saved the Daily Track to File to my Folder that I have for this Easter trip, yet the days file did not for some very strange thing did not save as a file, it was no data at all. Just as well that I was also using a GPS to also record the days data, as I had to import this to Ozi to have that days track on file.

I then reverted back to the older update and all working the way that it has been in the past, just great.

I hope that you have had a great Easter also.


Cheers



Stephen
Simpson Desert Colours

Lifetime Member
My Profile  My Blog  My Position  Send Message

0
FollowupID: 757817

Follow Up By: Member - Chris & Debbie (QLD) - Sunday, Apr 08, 2012 at 21:11

Sunday, Apr 08, 2012 at 21:11
The only way, Stephen, that I can recreate what you have happening is by NOT having the 'Log Track to File' ticked, and only having a tick on the 'Log Track Tail'.
As mentioned before, the track tail is not permanently recorded unless moved to track 1 then saved. But, the track will be automatically saved if log track to file is ticked.
If you do have both these options ticked then I am at a lose.
It may be worth you using the NMEA simulator and playing with all the different options .

Cheers
Chris
AussieHF touring club. 1089
-------------------------------------------

Member
My Profile  My Blog  My Position  Send Message

0
FollowupID: 757824

Sponsored Links

Popular Products (13)