Very slow to load

Submitted: Monday, Jun 11, 2012 at 22:27
ThreadID: 96202 Views:1795 Replies:19 FollowUps:15
This Thread has been Archived
Is it just me and my computer or do others experience extremely slow
loading of pages and topics? If it's just me I can look into why it's so.
When I click on a topic it takes ages to load.
Am I alone with this?
Norm
Back Expand Un-Read 0 Moderator

Reply By: Member - Royce- Monday, Jun 11, 2012 at 22:46

Monday, Jun 11, 2012 at 22:46
fine on mine...
AnswerID: 488224

Reply By: Dennis Ellery - Monday, Jun 11, 2012 at 23:05

Monday, Jun 11, 2012 at 23:05
Test your computer against other websites at the same time of the day.
I have found Exploroz to be very slow at times, whilst other websites are performing well at the same time.
AnswerID: 488226

Follow Up By: AlbyNSW - Monday, Jun 11, 2012 at 23:06

Monday, Jun 11, 2012 at 23:06
That has been my experience too, Exploroz is slower than other sites
0
FollowupID: 763450

Follow Up By: Member - Stephen L (Clare SA) - Tuesday, Jun 12, 2012 at 07:42

Tuesday, Jun 12, 2012 at 07:42
Hi Dennis

I also have done the same, blaming no internet, but works well with other sites.

I also compare Firefox, Explorer, Google Chrome and Safari (My usual Tool) and they are all the same. Perhaps it is time for David to have another play and tweak again.

Cheers


Stephen
Simpson Desert Colours

Lifetime Member
My Profile  My Blog  My Position  Send Message

0
FollowupID: 763457

Follow Up By: Polaris - Tuesday, Jun 12, 2012 at 09:05

Tuesday, Jun 12, 2012 at 09:05
SLOOOOOWWWW.

Mine too.

Need to be very patient on this site.

Good site though ....

Polaris
0
FollowupID: 763468

Follow Up By: member - mazcan - Tuesday, Jun 12, 2012 at 12:53

Tuesday, Jun 12, 2012 at 12:53
hi all
yes its a slow site and i used to blame my old worn out and dated computor but now i have a high quality laptop nothing much has changed with this site still being the slowest site in response time
all other sites will flash onto the screen in split seconds but not eo
last year when i discussed it with eo admin they told me it was my old computor and i needed to get it looked at but i have now proved and am satisfied the problem is in their system somewhere
i generally enjoy the eo website but it gets so annoying some days/nights that i change to another site or switch off ashave tryed all the other things mentioned above in other replies but it makes no and/or little difference
it can be a pain in the butt
cheers
barry
0
FollowupID: 763486

Reply By: brianc - Monday, Jun 11, 2012 at 23:31

Monday, Jun 11, 2012 at 23:31
Don't know all the tricks, however we changed our browser to Google Chrome the other week, and ALL sites load faster. EO was slow, not now.
AnswerID: 488231

Reply By: NRK - Monday, Jun 11, 2012 at 23:48

Monday, Jun 11, 2012 at 23:48
Sometimes a reboot of your whole system including your modem will help, I use Firefox for browser and find it much faster than IE, and as brianc said, Chrome is also fast, and both of these load images and topics very quickly
AnswerID: 488232

Follow Up By: Member - Hillel K (VIC) - Tuesday, Jun 12, 2012 at 07:46

Tuesday, Jun 12, 2012 at 07:46
I also find this site extremely slow to load .
0
FollowupID: 763458

Reply By: Member - Walter H (WA) - Tuesday, Jun 12, 2012 at 00:01

Tuesday, Jun 12, 2012 at 00:01
I have agree with you Norm, as all other sites are fast but EO takes for ever at times and can be frustrating .

Wal
AnswerID: 488233

Reply By: bibtracker - Tuesday, Jun 12, 2012 at 00:10

Tuesday, Jun 12, 2012 at 00:10
ExploreOz is no slower for me than other sites, but ALL sites are slow becos of my terrible wireless internet reception a mere 14km from the centre of Perth (apparently I'm in a little, localised black spot).
However, recently ExOz has been "freezing" from time to time and needs to be "reopened" before I can continue viewing/reeading.
I may try Chrome to see if it's any better.
Cheers, Tony
AnswerID: 488235

Reply By: rainbowprof - Tuesday, Jun 12, 2012 at 01:26

Tuesday, Jun 12, 2012 at 01:26
I find EO slower than many (if not most) other sites. Fortunately it's worth the wait...
AnswerID: 488238

Reply By: Peter_n_Margaret - Tuesday, Jun 12, 2012 at 06:12

Tuesday, Jun 12, 2012 at 06:12
EO is terribly slow for me, due no doubt to every corner being jammed with advertisements. Worse than any other site I visit and it does dramatically reduce how often I come here and how often I contribute.
What was once a great site being wrecked by commercialism, in my view.

Cheers,
Peter
OKA196 Motorhome.
AnswerID: 488239

Follow Up By: ExplorOz - Tuesday, Jun 12, 2012 at 11:22

Tuesday, Jun 12, 2012 at 11:22
Guys, these sorts of posts are most upsetting to read as they are so full of heresay instead of fact it doesn't help us determine if there is a genuine issue. Please forward any emails reporting errors or problems to the inbox for direction attention.

Some facts:
1. ads on this site are not part of the page load - they are externally served so have nothing to do with page load times.
2. EO would undoubtedly take longer than other simple sites to load - there is some very complex features - auto keyword lookups, member/user profile management, mapping engine etc. Live dynamic site etc. But still shouldn't be long enough to warrant comment.
3. We always advise you keep your browser upgraded to the latest version to cope with the complexity of the site features. Some browsers are better than others and whilst IE is still used by the majority it tends to be the one performs the worst. Try Firefox instead.
4. We work live on the site across 3 different browser platforms and 5 desktop machines plus a tablet, an iphone, an android, and a laptop which means we are constantly getting feedback about live site performance. Invariably, when people reports issues that we're not seeing, it turns out to be on their end.
5. If all else fails, please email the inbox.

Michelle
ExplorOz

Business Member
My Profile  My Blog

0
FollowupID: 763480

Follow Up By: Peter_n_Margaret - Wednesday, Jun 13, 2012 at 16:07

Wednesday, Jun 13, 2012 at 16:07
Michelle, my report of the slowness of EO is not hearsay, it is what I experience here EVERYTIME I visit.
It does take at least twice as long to load any new page here as it does on any of the other forums that I visit.
That dfoes affect how often and how long I visit.

I am not a member and nor will I ever be, so maybe it is different for those who are, but this site is not what it was for me. It is just too hard to use and to contribute to and steadily getting worse, I feel.

Cheers,
Peter
OKA196 Motorhome
0
FollowupID: 763569

Reply By: Ozhumvee - Tuesday, Jun 12, 2012 at 07:58

Tuesday, Jun 12, 2012 at 07:58
It is slower as Peter said because of all the crap running in the background but as that pays for it all then I guess we'll have to put up with it.
On a side note if it is very slow it may be time for a new Puter, my faithful old PC case that had been going for about 10 years with several upgrades, replacement motherboards etc etc fell over and my friendly computer mate talked me into building a new one, not over the top but pretty much up to date and the difference is amazing, most things load with virtually no delay and it makes surfing a much more pleasant experience.
Peter
1996 Oka Motorhome

Member
My Profile  My Position  Send Message

AnswerID: 488242

Reply By: Member - Ups and Downs - Tuesday, Jun 12, 2012 at 08:23

Tuesday, Jun 12, 2012 at 08:23
Doesn't matter what age your computer is. The comparison of speed is relative.

For me ExplorOz is very frustrating due to the slowness.

Other sites wizz through the pages on our near new computer, not here though.

Paul
AnswerID: 488244

Reply By: olcoolone - Tuesday, Jun 12, 2012 at 08:29

Tuesday, Jun 12, 2012 at 08:29
Flash animated sites are painful but they do look pretty and yes there is a lot of stuff running in the background.

75% of the time I din't have a problem with EO load times.... the other 25% it gets to a point where I just go to a different site for awhile.

This is the only site I have problems with and it doesn't matter what computer I use on what modem.

AnswerID: 488245

Follow Up By: Life Member - esarby (NSW) - Tuesday, Jun 12, 2012 at 08:38

Tuesday, Jun 12, 2012 at 08:38
I have found it slow at times running I E 9. Try blocking programs that you do not want to load at start up. I only have four of them to load and then start up other when needed.

Lifetime Member
My Profile  My Blog  Send Message

0
FollowupID: 763460

Follow Up By: Member - Boo Boo (NSW) - Tuesday, Jun 12, 2012 at 08:42

Tuesday, Jun 12, 2012 at 08:42
And I thought it was just me. lol

Quite often I have found it soooooooo,,,,, slow to get on too. Yet as others have said I can get on too other sites without any problems at all.

0
FollowupID: 763461

Reply By: Member -Pinko (NSW) - Tuesday, Jun 12, 2012 at 09:48

Tuesday, Jun 12, 2012 at 09:48
Compared with other sites ... very slow, but worth waiting for.
Living is a journey,it depends on where you go !
VKS 737 mobile 0049 selcall 0049

Member
My Profile  My Position  Send Message

AnswerID: 488251

Reply By: The other Norm C (WA) - Tuesday, Jun 12, 2012 at 09:57

Tuesday, Jun 12, 2012 at 09:57
Thanks all for your replies
At least i know it's not just me
Norm
AnswerID: 488252

Reply By: ExplorOz - Tuesday, Jun 12, 2012 at 11:25

Tuesday, Jun 12, 2012 at 11:25
Guys, these sorts of posts are most upsetting to read as they are so full of heresay instead of fact it doesn't help us determine if there is a genuine issue. Please forward any emails reporting errors or problems to the inbox for direction attention.

Some facts:
1. ads on this site are not part of the page load - they are externally served so have nothing to do with page load times.
2. EO would undoubtedly take longer than other simple sites to load - there is some very complex features - auto keyword lookups, member/user profile management, mapping engine etc. Live dynamic site etc. But still shouldn't be long enough to warrant comment.
3. We always advise you keep your browser upgraded to the latest version to cope with the complexity of the site features. Some browsers are better than others and whilst IE is still used by the majority it tends to be the one performs the worst. Try Firefox instead.
4. We work live on the site across 3 different browser platforms and 5 desktop machines plus a tablet, an iphone, an android, and a laptop which means we are constantly getting feedback about live site performance. Invariably, when people reports issues that we're not seeing, it turns out to be on their end.
5. If all else fails, please email the inbox.

Michelle
ExplorOz

Business Member
My Profile  My Blog

AnswerID: 488263

Follow Up By: patsproule - Tuesday, Jun 12, 2012 at 11:57

Tuesday, Jun 12, 2012 at 11:57
Michelle - this might be related... it seems one of the regular advertisers' animations might be causing some problems again - occasionally when loading the forum page my CPU will sit at 100% (on a 3 Gig i7!) and all cooling fans will spool up to max for about 10 seconds, then settling back down. I'm not sure which advertiser is doing it but will try and send you a screen cap when it does it again. Using Chrome on a Macbook Pro OSX 10.6.8.
0
FollowupID: 763483

Follow Up By: Member - MUZBRY(Vic) - Tuesday, Jun 12, 2012 at 12:56

Tuesday, Jun 12, 2012 at 12:56
Gday
I am like my three year old grand daughter , she says," turn it on and be patient " then if all else fails, call for nanny.

Muzbry
Great place to be Mt Blue Rag 27/12/2012

Lifetime Member
My Profile  Send Message

0
FollowupID: 763487

Follow Up By: olcoolone - Tuesday, Jun 12, 2012 at 13:35

Tuesday, Jun 12, 2012 at 13:35
Michelle, I think you will find it's not all the time..... you might load EO 9 times and the 10th time it hangs... you might then not have a problem for another 6 page loads then the 7th time it will not load..... then there may not be an issue for another few days.

Don't know if you can run a poll to gauge the time it's happening.

I don't know if it happens when you are updating your server or some thing else is running.



0
FollowupID: 763493

Follow Up By: Member - Rod N (QLD) - Tuesday, Jun 12, 2012 at 13:51

Tuesday, Jun 12, 2012 at 13:51
Mine is the same as olcoolone. Slow sometimes. I don't do any thing to my comp but when I try later it is OK.
0
FollowupID: 763495

Follow Up By: Bazooka - Tuesday, Jun 12, 2012 at 13:54

Tuesday, Jun 12, 2012 at 13:54
Yes the internet is a complex place with peering, piping, sharing etc so it's hard for users to pinpoint where blockages are actually occurring. More often than not it's to do with the ISP's 'network' rather than a site's server/software. The relative loading speed of different websites is (unfortunately) not in itself a great indicator of problems with a particular site.

When a site won't load for me at all I try 'Down For Everyone or Just me' which is a pretty good indication (although not foolproof itself).
0
FollowupID: 763496

Follow Up By: P and JM - Wednesday, Jun 13, 2012 at 16:25

Wednesday, Jun 13, 2012 at 16:25
It's seem to be always slow. That slow I get another six grey hairs on my head waiting for it to happen !!

Cheers
0
FollowupID: 763571

Reply By: Horacehighroller - Wednesday, Jun 13, 2012 at 16:51

Wednesday, Jun 13, 2012 at 16:51
As some on here have indicated - sometimes it is extremely slow.
But most of the time it is OK for me.

I don't know wether it's related to the number of users trying to access at the one time (evening??) but I do know that after 3.30 PM EVERYTHING slows down.
I'm convinced that it's related to all the kids getting home from school and jumping on the net.

Peter (Optus Cable and a new(ish) puter.)
AnswerID: 488390

Reply By: SDG - Wednesday, Jun 13, 2012 at 20:53

Wednesday, Jun 13, 2012 at 20:53
I'm going out on a limb here, but I find it to be the same as any other site if not faster.

Maybe because i'm still on dialup?
AnswerID: 488413

Reply By: Member - John (Vic) - Wednesday, Jun 13, 2012 at 23:35

Wednesday, Jun 13, 2012 at 23:35
Runs very well here, quick to load as comparable to most other sites I use.
If I experience problems its because of a known issue such as an EO server issue or David is doing something in the background etc.

I still think so many of the issue's people complain about are local, related to the ISP or broadband type being used, modem or software issues on their machine etc.

The site is complex, must be way more than 80,000 pages David mentioned it was a year or two ago by now and it does some brilliant stuff, Places, Treks, Blogs etc with their interactive abilities.

The advert issue caused problems awhile back for some who were not running the latest Flash version, moral of the story is make sure all your software is up to date.

Also David is totally pro active in responding to issues, in my view nothing is ignored as testament to his replies to posts about faults, suggestions etc made by people on the Forum plus as Michelle has said they use and monitor the site for issues constantly so would without doubt fix any issue as soon as its apparent to them.
To much time, effort and money invested not to be pro active in managing their site. After all its how they actually feed the kids.

VKS737 - Mobile 6352 (Selcall 6352)

Lifetime Member
My Profile  My Position  Send Message

AnswerID: 488423

Reply By: Member - Rod N (QLD) - Saturday, Jun 16, 2012 at 15:37

Saturday, Jun 16, 2012 at 15:37
Did anyone have a problem with this site from 1512 to 1530 today, 16 Jun. Nothing would load or re-load. All other sites were OK.
AnswerID: 488626

Reply By: PeteS - Sunday, Jun 17, 2012 at 19:35

Sunday, Jun 17, 2012 at 19:35
It's also my experience of the last week or so that ExplorOz is much slower than the other sites I regularly visit. It seem to take a big breath after any page visit or action I do on it.

Not complaining, just providing feedback.

Cheers,
PeteS
AnswerID: 488753

Sponsored Links

Popular Products (13)