Nissan 2001 GUII TD42T Wagon Sub tank Pump

Submitted: Tuesday, Apr 29, 2014 at 17:01
ThreadID: 107529 Views:1482 Replies:4 FollowUps:0
This Thread has been Archived
Does anyone out there know where I can get a sub tank pump from? I am certainly not willing to pay Nissan $600 plus for this pump. My pump light comes on when the sub tank switch is pushed, but all I get at the main tank filler is a few drips of diesel, not a constant flow like there used to be. I have run extra earthing cables, but no joy....Any info would be greatly appreciated

Thanks
Back Expand Un-Read 0 Moderator

Reply By: pepper2 - Tuesday, Apr 29, 2014 at 17:25

Tuesday, Apr 29, 2014 at 17:25
Have you tried NIZZBITS they are on the net,have everything for nissan,also you could go to the nissan patrol forum for advice and you can also buy many parts there,
all the best.
AnswerID: 531490

Reply By: duck - Tuesday, Apr 29, 2014 at 18:42

Tuesday, Apr 29, 2014 at 18:42
My switch pump light will come on but not pump after I have blown the fuse & change it & it will still not work, but Disconnect the battery for a few mins & it's all fine needs time to reset this is common on gu there will be a few threads about it.
If it is the pump there are plenty of 4wd wreckers in most states that will have them & remember to always have fuel in aux tank as most only die due to being run dry & a lot of owners do not relies that every time you start the ignition the pump starts for a few seconds
Regards
AnswerID: 531496

Reply By: Michael ( Moss Vale NSW) - Tuesday, Apr 29, 2014 at 19:30

Tuesday, Apr 29, 2014 at 19:30
Tony , Lucky you have a 4.2TD, if it was a 3 litre you would have replaced everything that hangs of the motor and eventually the engine itself! If you have as many ks on your Patrol as mine, you would probably be on your second replacement engine. So $600, although ridiculous is probably not too bad in the scheme of things in a 13 yo vehicle! Anyway get onto the Patrol 4x4 Forum as there is plenty of options for you choose from in many discussions about the problem. From memory $150 on Ebay will get you out of trouble so check on that forum for details. regards Michael
Patrol 4.2TDi 2003

Retired 2016 and now Out and About!

There's time to rest when you're dead,
Get out and do something instead!

Member
My Profile  My Blog  My Position  Send Message

AnswerID: 531497

Reply By: Member - bob s - Wednesday, Apr 30, 2014 at 08:47

Wednesday, Apr 30, 2014 at 08:47
Hi Tony R11.
Had the same problem with my sub tank pump when i had my patrol.
Looked everywhere for a solution. Someone suggested to look on the
Patrol forum. There was quite a bit of information on the subject.
One particular post caught my eye. A guy had the same problem so he
got in a quiet area, switched his aux pump on, crawled under the car and
gave the pump a few sharp knocks with a small hammer. I tried this and
it worked. Had to do it a few times for about a month but it finally freed up and
no more problems.

Cheers Bob s

PS Make sure your main tank is under 3/4 full or the pump wont work.
AnswerID: 531512

Sponsored Links

Popular Products (13)