Electrical issue

Submitted: Tuesday, May 27, 2014 at 18:27
ThreadID: 107973 Views:1398 Replies:5 FollowUps:0
This Thread has been Archived
Ok this one has me stumped.... I had a wire short out on the metal on hand brake this morning, this caused the lights, radio, UHF, indicators and central locking to stop working....... I have checked all the fuses they're all fine

Any ideas??

forgot to add its an old 89 Triton
Back Expand Un-Read 0 Moderator

Reply By: Ross M - Tuesday, May 27, 2014 at 19:01

Tuesday, May 27, 2014 at 19:01
Did you test all fuses with a multimeter to check integrity of the fuse? ie multimeter on ohms 200?
Maybe the fuse which has blown isn't one of the ones you have found yet.
AnswerID: 533259

Reply By: HKB Electronics - Tuesday, May 27, 2014 at 19:52

Tuesday, May 27, 2014 at 19:52
You most likely have blown a fuse or a fusible link.

As above check with a meter as sometimes it is hard to see if they are blown.

Also as multiple circuits aren't working I would subbest it is a fusible link that has ruptured.

Cheers
Leigh

Lifetime Member
My Profile  Send Message

AnswerID: 533265

Reply By: howesy - Tuesday, May 27, 2014 at 20:37

Tuesday, May 27, 2014 at 20:37
check battery, mine has 2 fusible links and if one goes it takes out all those accessories
AnswerID: 533266

Reply By: southy - Tuesday, May 27, 2014 at 21:32

Tuesday, May 27, 2014 at 21:32
Thanks guys will do
AnswerID: 533276

Reply By: southy - Wednesday, May 28, 2014 at 15:33

Wednesday, May 28, 2014 at 15:33
Yep it was a fuseable link, not the ones off the battery but one tucked away on the drivers side just below the windscreen which had corroded
AnswerID: 533321

Sponsored Links

Popular Products (13)