oven/cooktop/grill model DF500DIT-T2

Submitted: Friday, Jul 03, 2015 at 15:32
ThreadID: 119384 Views:1337 Replies:2 FollowUps:2
This Thread has been Archived
We have a 2003 jayco outback with the above model oven/cooktop(3gas 1 electrc)/grill. One of the gas burners on the cooktop will light but on releasing the knob will on 95% of occasions go out or with an extremely low flame which most times go out completely some short time later. I have cleaned the burner and inserted a light gauge pin in the jet to eliminate any blockage in the jet, I have also dis-assembled the knob housing and cleaned this thoroughly (it was full of some sort of grease/lubricant). On putting everything back and trying system same issue no go when I released gas knob burner goes out, can keep it going as long I keep knob pressed in.

Can any body offer some advise on rectifying this issue.

Regards,

John and Kerrie
Back Expand Un-Read 0 Moderator

Reply By: Mikee5 - Friday, Jul 03, 2015 at 16:40

Friday, Jul 03, 2015 at 16:40
I am not a guru but here goes. There is a sensor thingy which gets in the flame. If it is hot it will keep the gas on. If it is cold it will cut the gas off. Holding the knob in overrides the thing until it gets hot. Sounds like it is this area you should be looking at. Good luck
AnswerID: 556624

Follow Up By: John Z - Friday, Jul 03, 2015 at 17:52

Friday, Jul 03, 2015 at 17:52
Thanks for that, will try that.

Regards: John Z
0
FollowupID: 842865

Reply By: Notso - Friday, Jul 03, 2015 at 18:46

Friday, Jul 03, 2015 at 18:46
Have you got any other Gas appliances? If so, does it work?

There were a number of vans around the same vintage as yours that had faulty gas regulators. It is possible that the regulator is blocked but letting a little gas through but not enough to sustain the flame.
AnswerID: 556630

Follow Up By: John Z - Friday, Jul 03, 2015 at 21:10

Friday, Jul 03, 2015 at 21:10
Have test the flow by turning fridge on to gas mode (working), while fridge was operating on gas, turned on the other two cook top gas burners they worked at full bore, 3rd burner only worked while I held knob down.
It appears that gas is flowing to other gas items but not the problem burner. I tested problem burner with all other items not on i.e. fridge & 2 burners it still did not work?
0
FollowupID: 842874

Sponsored Links

Popular Products (13)