problem with cruise control on 80s

Submitted: Monday, Jun 17, 2002 at 00:00
ThreadID: 1316 Views:1357 Replies:1 FollowUps:1
This Thread has been Archived
can anyone provide me with info on the rostra cruise control for 80s cruiser? i have one fitted to my turbo d auto. it works fine until it kicks down then it won't stop accelerating & is very difficult to deactivate. it was very hairy the first time it happened!! any help on this subject would be greatly appreciated.
thank you,Wal...
Back Expand Un-Read 0 Moderator

Reply By: Revs - Wednesday, Jun 19, 2002 at 00:00

Wednesday, Jun 19, 2002 at 00:00
Wal, I assume the Rosta CC is an "after market" unit? I am only guessing, but I suspect that you may have a problem where the vacuum line that sucks the piston back , operating the CC., is not being shut off electrically. ie: the suction is maintained on the piston of the CC unit even though the dump valve is fully open. There are two valves in the operating unit, one to open the vacuum line (effectivelly pulling the piston back, speeding up the car), and another valve to "dump" the vacuum, (which works in tandem with the other valve, ie: opens when the other closes, to slow down the car) I suggest you check the continuity of both these valve with a multi meter. This MAY identify the problem. Good luck.
AnswerID: 4310

Follow Up By: Wal Troy - Wednesday, Jun 19, 2002 at 00:00

Wednesday, Jun 19, 2002 at 00:00
thanks Revs. that sounds logical. i'll give it a go & let you know how it turns out.
thanks again Wal.
0
FollowupID: 1842

Sponsored Links

Popular Products (13)