80 series sahara console fridge

Submitted: Saturday, Jun 04, 2016 at 10:18
ThreadID: 132641 Views:2658 Replies:2 FollowUps:3
This Thread has been Archived
Hi all,
I have an issue with the factory ice/cooler centre console fridge in my 80 series sahara, that I'd be very much appreciative if anyone could help me out with.

I'll start with the embarrassing bit first.

Bought a new starter battery and after chucking it in and throwing the terminals on (while talking on the phone) I realised I'd bought the wrong battery, terminals opposite ?? large puff of smoke and some filthy words at myself followed!!!

Result, blown fusible link, 12 blown blade type fuses and a lot of reassuring words about how dumb I was from the wife.

Got everything fixed except the factory console fridge. Lights come on when buttons are pressed but no fan or anything. All the a/c's work front and back and the rear heater relay works. I'm thinking it's the amplifier but can't find out any info on them or how to test them, even repair manuals are very basic in information about them. Can't even find a replacement on ebay or such.

Any help or direction to head in would be greatly appreciated from anyone, after you stop laughing at my stupidity that is haha...


Back Expand Un-Read 1 Moderator

Reply By: Joe Fury - Saturday, Jun 04, 2016 at 11:51

Saturday, Jun 04, 2016 at 11:51
G'day David

No laughing matter, well not from me at least.

I've done pretty much the same thing too, but no phone chat involved in my scenario, no smoke release from the wires either, I was lucky and twigged when the main positive cable didn't reach the battery post.

I also own an 80 series Sahara, but have as yet not had major electrical issues, even with a triple battery set up.

Have a look through the "Offroad 80's" web site pages, or "Lcool", or if you have the patience to wade through the "I Hate mud" web pages ~ you may well find an answer, there is also an American web site that is very detailed with information on all things mechanical and auto electrical to do with Land Cruisers, just search the 4x4wire pages.

Nope, still not laughing.

Safe travels : Joe
AnswerID: 600950

Follow Up By: David P35 - Saturday, Jun 04, 2016 at 11:59

Saturday, Jun 04, 2016 at 11:59
Thanks mate, I'll check them out.

Cheers.
0
FollowupID: 870317

Reply By: Batt's - Saturday, Jun 04, 2016 at 11:52

Saturday, Jun 04, 2016 at 11:52
Might be a job for an auto elec.
AnswerID: 600951

Follow Up By: David P35 - Saturday, Jun 04, 2016 at 12:01

Saturday, Jun 04, 2016 at 12:01
Yeah, that's what I'm worried about. Even more worried that the spare parts like the amplifier aren't available anymore as I can't find them anywhere on the net except a few old Japanese second hand sale sites.

Cheers
0
FollowupID: 870318

Follow Up By: Batt's - Saturday, Jun 04, 2016 at 13:37

Saturday, Jun 04, 2016 at 13:37
If it cost to much to fix you can always replace it with a Waeco CDF11 just fitted mine to my GQ yesterday.
1
FollowupID: 870326

Sponsored Links

Popular Products (13)