ctek d250s error

Submitted: Sunday, Oct 23, 2016 at 22:24
ThreadID: 133652 Views:5105 Replies:7 FollowUps:2
This Thread has been Archived
See video for error sequence I'm getting on my ctek d250s



If I disconnect the service battery (its actually 2 battery value AGMs wired in parallel) and reconnect I can make the error stop for a few minutes, but it comes back.

If I disconnect the solar all lights on charger go off.

If I disconnect the service battery and leave it disconnected the charger seems to stay functioning.

The service batteries are currently showing 12.5v.

Any ideas? I suspect its something to do with the state of charge of the service battery's.

Its actually a laptop power supply connected to the solar input putting in about 19v 5A. Today I connected solar panels with similar voltage and amps with identical effect - so I don't think 'solar' source is the issue.

The vehicle is off.

Back Expand Un-Read 0 Moderator

Reply By: SuperGrover - Sunday, Oct 23, 2016 at 23:29

Sunday, Oct 23, 2016 at 23:29
If it is charging the batteries fine off of the solar input why do you not take the lead off of the input from the vehicle and place that on the solar input and see what it does. The unit should run fine if all is correct as I run both my solar and input from my car into the solar input via a selector relay. It may be that the 5amp laptop supply to your solar input is dropping its voltage as soon as the system tries to place it under load as the batteries are so flat. Maybe bring the batteries up to full charge via 240 v charger/generator if available.
AnswerID: 605356

Reply By: Sand Man (SA) - Monday, Oct 24, 2016 at 07:18

Monday, Oct 24, 2016 at 07:18
Tim,

Sounds like you have "cooked" the solar circuit on your D250S.
Separate the batteries and try the charging process on each one at a time, to identify if one battery is faulty.

Using a laptop power supply on the solar input port doesn't sound like a good idea to me. This circuit employs an MPPT solar controller and the "regulated" input the power supply is providing is different to that which an unregulated solar panel would be providing.

Does the charger work OK on the battery bank when operating from the Alternator input? i.e. are both batteries reaching full charge?
If so the solar charging capability has been compromised by use of the power supply on the solar port.
Bill


I'm diagonally parked in a parallel Universe!

Member
My Profile  My Blog  My Position  Send Message

AnswerID: 605360

Reply By: Tim Owen - Monday, Oct 24, 2016 at 20:26

Monday, Oct 24, 2016 at 20:26
Well I charged the service battery on a 240v charger and then reconnected the service battery to the ctek and all seems fine again. The laptop power supply still connected - I think that's a red herring.
AnswerID: 605382

Reply By: Battery Value - Monday, Oct 24, 2016 at 23:45

Monday, Oct 24, 2016 at 23:45
Hi Tim,

having watched the sequence of the lights, I'm pretty sure that's caused by the batteries over-loading the 19V supply through the ctek.
Computer power supplies momentarily switch off their output to protect themselves against too much current draw.
The ctek reacts to this by releasing its grip waiting for the voltage to recover, before opening the throttle again and the cycle repeats.

Of course when the batteries are reasonably charged, they gradually lose their appetite for charge and at some point the charging current will fall within the power supply's rating which then works smoothly.

There are other MPPT regulators such as the Victron MPPT75-15 which have an adjustment for max current. On these you'd, select a current which can be sustained by the power supply indefinitely for smooth and thorough charging - no more power supply hiccups when the SOC is low.

Regards, Peter
Battery Value Pty Ltd
AnswerID: 605384

Follow Up By: Tim Owen - Tuesday, Oct 25, 2016 at 19:58

Tuesday, Oct 25, 2016 at 19:58
Thanks Peter - best theory yet. Every now and then I am observing the solar slight turn off momentarily when connected to the laptop charger. What has me beat about this though is that I observed the ctek exhibit exactly the same behaviour when connected to an unregulated solar panel.

I thought all was well after charging the battery with the 240v charger. Tonight when I inspected the light to the service battery was out. I checked the voltage of the service batteries which was 12.9+ V, so I thought I'd add a load and see what happened. As soon as I turned the fridge on (a load to the service battery), the ctek went back into this same error sequence.

After disconnecting and reconnecting the service battery, I got it working again ... but I cannot have such an unstable system. I liked it when it 'just worked'.

Any further ideas? The other part of the equation is the starter battery (a CAT sealed lead acid) which unfortunately was recently discharged down to 2v while we were away for 4 months. It has also been charged on the 240v charger and is working again, but is only getting up to around 12.3V - I guess permanently harmed by the ordeal.
0
FollowupID: 875155

Reply By: Battery Value - Tuesday, Oct 25, 2016 at 21:48

Tuesday, Oct 25, 2016 at 21:48
Hi Tim,
unfortunately I know nothing about the ctek, but you're moving on thin ice when connecting a power supply to its input because it's not designed for this.
The fact that it now puts on this flicker show even with solar panels connected doesn't sound good at all.
If it keeps doing this with solar panels after double and triple checking all connections on the input and output side I'd get it checked out.
Also make sure the common negative connection for solar, battery, and input is in good nick.
What wattage are your panels?
AnswerID: 605414

Follow Up By: Tim Owen - Tuesday, Oct 25, 2016 at 21:58

Tuesday, Oct 25, 2016 at 21:58
OK, I'll put the laptop power supply away. It's funny - my other cheap chinese MPPT charger don't seem to mind the laptop power supply at all.
It's three panels wired together totaling about 180W ... but it was overcast here the day this all started. Output would have been low - I'd guess just a few amps, but I didn't measure it.
It'll have to wait till the weekend now before I can check it all with the solar properly in daylight hours. Hopefully with some sun this weekend.
0
FollowupID: 875163

Reply By: The Bantam - Wednesday, Oct 26, 2016 at 16:29

Wednesday, Oct 26, 2016 at 16:29
The first thing you need to remember is that "Smart Charger" is a sales term ...... these electronically controlled chargers are far from smart and can be confused.

Lets start with the MPPT regulator ....... it is designed to load down the solar panel till it achives the maximum amount of power out of it at any given time ....... so it will load down the source ( should be a panel) till the just voltage drops and the current does not ... or something similar ....... so it's going to push your laptop power supply in to or to the verge of overload ......... how the laptop power supply will respond is anybodies guess ..... it may foldback current limit or or may shut down momentarily.

If it shuts down the MPPT reg will them slacken its grip on the PSUs throat and it will come back to life ...then the MPPT reg will strangle it again ...... this may be one explanation.

The other MPPT reg may not be big enough or it may not be as aggressive..... thus may run.

If you want a simulated solar panel you will need a regulated power supply and a series resistance to mimic the solar panel behaviour ....... one of the solar gurus may be able to tell you what this series resistance needs to be .... it could be quite high. ... and a resistor capable of copping the full output of the PSU

Pretty much all of these "smart chargers" can be confused when they are presented with something on their terminals that is outside what they are programed to deal with. ... they may do strange things or simply shut down.

well known issues are.

Strange and out of spec voltages or behaviors on their inputs
Batteries at very low or very high states of charge
Batteries that do not show a healthy charging behavior

so give it what it expects to see ...... it might run.

cheers
AnswerID: 605432

Reply By: Tim Owen - Wednesday, Nov 02, 2016 at 07:34

Wednesday, Nov 02, 2016 at 07:34
Just to close this off .... once I gave the ctek a break from the laptop power supply, and reconnected 'regular' solar panels it seems to be back functioning normally.

What stumped me was when I switched from the laptop supply to the solar it exhibited the same behaviour ... but I guess I didn't give it sufficient time to think/reset itself.

And heres a plug for battery value AGMs, I've got 2 (I think 95ah) AGMs wired in parallel in my camper box - they are now over 5 years old, and still holding 12.95V when fully charged. I'm sure there is nothing too defining in that claim, but I'm happy with the service I've had, and continue to enjoy from them.

Other than the self inflicted trouble reflected in this thread, I have to say I've also enjoyed the 'set and forget' arrangement with the ctek too.
AnswerID: 605627

Sponsored Links

Popular Products (13)