105 series cruise control

Submitted: Tuesday, Jun 12, 2018 at 16:11
ThreadID: 136825 Views:505 Replies:2 FollowUps:2
This Thread has been Archived
Ok brains trust, my 105 petrol cruiser cruise control has stopped working.
Light comes on the dash and I can hear the relay click but no luv at the wheels, any ideas before I visit the auto electritian
Back Expand Un-Read 0 Moderator

Reply By: RMD - Tuesday, Jun 12, 2018 at 16:57

Tuesday, Jun 12, 2018 at 16:57
Check your brake lights and park lights. If a globe is faulty or broken filament touching the park filament or similar, it sends a voltage to the brake light switch and appears to the cruise system as though you are braking. Check globes and the base connection in the holder plus a lok for everything being proper in the trailer plug and base.
AnswerID: 619498

Follow Up By: Allan B (Sunshine Coast) - Tuesday, Jun 12, 2018 at 18:46

Tuesday, Jun 12, 2018 at 18:46
.
And make certain that your hand-brake is fully off.
Cheers
Allan

Member
My Profile  My Blog  Send Message

0
FollowupID: 891789

Reply By: Athol W1 - Tuesday, Jun 12, 2018 at 20:47

Tuesday, Jun 12, 2018 at 20:47
Martian

In addition to checking that all the lights are FULLY functional (check brake lights with tail lights already lighted and look for the change in intensity) I would also be looking at the Bowden cable from the CC motor to the engine throttle plate.

I have been able to have these cables made up by visiting the local boating supplier, as they use similar cables for some of their outboard motor controls.

Regards
Athol
AnswerID: 619505

Follow Up By: Martian67 - Wednesday, Jun 13, 2018 at 21:03

Wednesday, Jun 13, 2018 at 21:03
Gday Athol, checked it out and it was a broken cable!
Thanks for the input.
0
FollowupID: 891821

Popular Content

Popular Products (15)