ctek 250s dual issues

Submitted: Sunday, Jul 22, 2018 at 17:58
ThreadID: 137020 Views:680 Replies:3 FollowUps:1
This Thread has been Archived
hey there guys,
have a problem or may not with my 120w solar panel (unregulated) that i wired into my ctek 250s dual. the panel is pulling 20.8v into the ctek and all the wiring in and out of the ctek and panel are correct but the battery light on the ctek is flashing, it hasn't happened before. wondering if anyone has come across this.
cheers
Back Expand Un-Read 0 Moderator

Reply By: IvanTheTerrible - Sunday, Jul 22, 2018 at 19:06

Sunday, Jul 22, 2018 at 19:06
What does the instructions say? There is a list of error codes.
AnswerID: 620285

Reply By: gothe100 - Sunday, Jul 22, 2018 at 19:20

Sunday, Jul 22, 2018 at 19:20
it says nothing in the manual mate looked through it from front to back. i did find something on it' but it was all errors for the smartpass
AnswerID: 620286

Follow Up By: IvanTheTerrible - Sunday, Jul 22, 2018 at 21:16

Sunday, Jul 22, 2018 at 21:16
Another thread same problem maybe

And also

I have a 250S Dual and connected the other day noted that the "SERVICE BATTERY" LED was flashing, what does this indicate as I couldn't find anything in the manual


Hello David;

It means the D250 charger is charging the start battery instead of the service battery. This is from the solar panel.

There are a number of Led combinations not listed in the user manual - some are actual faults, while others are functional.

Regards;

Kimbal Summers
Service & Warranty Technician
Bainbridge Technologies
0
FollowupID: 892695

Reply By: CSeaJay - Sunday, Jul 22, 2018 at 21:43

Sunday, Jul 22, 2018 at 21:43
Do a search, it appears not uncommon and there are at least two informative threads on here.
AnswerID: 620287

Popular Content

Popular Products (1)