Ipad Mini 3

Submitted: Wednesday, May 05, 2021 at 15:10
ThreadID: 141687 Views:522 Replies:3 FollowUps:3
Hi there,

I'm new to ExploreOZ and looking to pick up a cheap iPAD Mini 3 to run the maps on. Anyone here use that model and if so how does it run?

I know it's an older device, but I don't want something expensive being thrown around the car.
Back Reply Expand Un-Read 0 Moderator

Reply By: Member - rocco2010 - Wednesday, May 05, 2021 at 15:19

Wednesday, May 05, 2021 at 15:19
This quote from the Traveller FAQ might answer the question.

“Any smartphone, tablet, PC, iPad, or Android headunit that has inbuilt or external GPS connectivity & a fast memory/processor of 4GB+ RAM is ideal together with a supported version of the operating system (Android 8+, iOS 11+, Win10). Beware of using budget/low end devices or devices with unsupported versions of the operating system”

iPad mini3 uses iOS8, they are now up to 14.

I appreciate people have a budget but I doubt it would work well, if at all.
AnswerID: 636256

Follow Up By: Swamps - Wednesday, May 05, 2021 at 15:23

Wednesday, May 05, 2021 at 15:23
The Ipad Mini 3 is compatible upto iOS 12. which meets the requirements listed for the app.
0
FollowupID: 914121

Follow Up By: Member - rocco2010 - Wednesday, May 05, 2021 at 15:27

Wednesday, May 05, 2021 at 15:27
Ok , sorry. I must have looked at a different list.

Good luck with it.
0
FollowupID: 914123

Reply By: Swamps - Friday, May 07, 2021 at 16:46

Friday, May 07, 2021 at 16:46
I ended up buying an iPad Mini 4 for the better performance.. However, god this app is slow.. unusable on the Mini 4.. very disappointing.

You guys really need to update your system requirements page giving better details on what is required to use the app.
AnswerID: 636294

Follow Up By: Frank P (NSW) - Friday, May 07, 2021 at 17:52

Friday, May 07, 2021 at 17:52
This site says it has only 2GB RAM. This Apple page does not reveal the RAM. If the first one is correct, that explains it.

From the Traveller System requirements on this page

***"As a guide, look for a minimum spec of 3GB RAM for a tablet. If you can get one with 4GB RAM – even better. "***

Also it may need a firmware upgrade if the current firmware is below iOS11 or whatever that translates to in your device. (The web page above says it's upgradeable to IpadOS 14.5.1.)

FrankP

Lifetime Member
My Profile  My Blog  My Position  Send Message
Moderator

0
FollowupID: 914182

Reply By: Swamps - Friday, May 07, 2021 at 19:42

Friday, May 07, 2021 at 19:42
There is a big difference between Firmware and Operating System. the OS of the iPad mini 4 was iOS 8 when it came out, however it's still a supported device and I'm currently running iOS 14.5.

Ram may be an issue but I've never known an iOS app specify the ram requirements before, shows bad programming IMHO if it needs 3gb of ram. that's only available on the latest high end Ipads. my Iphone has 2gb of ram and it runs fine. I also use Gaia GPS which runs very smoothly on the same hardware. This should be made a lot clearer and checks in place by the developers to check compatibility before allowing purchase.

NONE of these RAM limitations are listed on the App purchase screen on the App store.

I've raised a support case, and also requested a refund through Apple. I'm sure the new 2021 Topo maps are excellent, but if the surrounding application is bloated and badly written then it doesn't matter how good the maps are.
AnswerID: 636300

Sponsored Links

Popular Products (13)