Waeco - Star Service

Submitted: Saturday, Jul 03, 2004 at 10:26
ThreadID: 14334 Views:1906 Replies:4 FollowUps:1
This Thread has been Archived
Over the past months I have had a problem with the motor on the CF50 cutting in and out ensuring that those prized amber fluids would not be down to the right drinking temperatue. I checked out the obvious things but nothing helped. Finally I emailed Weaco for some advice on the power cable telling them the story of what had happened to date. This was at 8.30pm on the Tuesday evening. A 10.15am Wednesday I received a call from the Waeco Service Manager, Danny Newman wishing to discuss my problem with me and offer a solution. Well it worked out the the plug was stuffed and he said that a replacement cable would be sent out under warranty. Remember this was only about 1.5 hours after he would have received my message on that morning. True to his word the cable was in my mail box on Thursday morning ready to assit in cooling down those beers.

In days when people often tell us of the lack of service they have encounted I wanted to praise a company and particularly Danny for his speed and conviction to customer service he engenders. He certainly left me with the feeling that as a customer I countered.

Which company do you think I will get my next fridge from?

( Have just noticed that Waeco are now a sponsor of this site. My comments are personal and have nothing to do with this sponsorship)

Cheers,

Patrick
Back Expand Un-Read 0 Moderator

Reply By: GOB & denny vic member - Saturday, Jul 03, 2004 at 12:52

Saturday, Jul 03, 2004 at 12:52
goodday patrick
which cable was it
i notified them some time ago of a problem with the fridge lead with the cigarette lighter end the fuse or something and a bitv of heat makes it go hard and not sit into the cigarette lighter ,falls out /disconnects i cut the end off and made a permanent connection to the power adapter for 240v and put a "T" plug on to suit the rest of my wiring in the car no problems with this setup

steve
AnswerID: 66274

Follow Up By: Patrick - Saturday, Jul 03, 2004 at 15:06

Saturday, Jul 03, 2004 at 15:06
The cable was the normal cigarette coonection from the back of the fridge to the mobitronic unit. I must admitt that the old one was a bit hard at the end after nearly 3 yeras and the spine did not move backwards or forwards very well. It's working great guns now!!!

Cheers,

Patrick
0
FollowupID: 327105

Reply By: Member - Toonfish - Saturday, Jul 03, 2004 at 17:15

Saturday, Jul 03, 2004 at 17:15
sponsors love these stories.

wish my prob was solved quicker !
AnswerID: 66300

Reply By: Shaker - Saturday, Jul 03, 2004 at 18:01

Saturday, Jul 03, 2004 at 18:01
I had equally as good a response from EvaKool with a power cable problem.
Great to know there are still manufacturers who actually care!
AnswerID: 66312

Reply By: floyd - Wednesday, Jul 07, 2004 at 20:04

Wednesday, Jul 07, 2004 at 20:04
Had the same problem with the same fridge. Solution was to cut the plug out of the scenario and hard wire the lead to the battery. Problem solved straight away.

Waeco servicing is fantastic. Had 2 warranties with them and fixed up without any hassles.
AnswerID: 66862

Sponsored Links

Popular Products (13)