Clutch leak

Submitted: Friday, Aug 23, 2002 at 00:00
ThreadID: 1801 Views:1064 Replies:3 FollowUps:1
This Thread has been Archived
G'day all,

I have a problem with my 88 SWB GQ that I cant seem to fix. I am having to top up my clutch fluid each week. I am using about half the container every 5 days. I cannot find any drips on the carport floor, I have had the master cylinder replaced and all hoses are in good condition. Only seem to lose fluid when driving as I don’t drive the car mid week and the level does not change when idle.
Any ideas folks??

Cheers Grazza
Back Expand Un-Read 0 Moderator

Reply By: steve - Friday, Aug 23, 2002 at 00:00

Friday, Aug 23, 2002 at 00:00
HI Grazza It seems to me you are pumping the fluid out every time you depress the clutch. Sit in the vehicle when in the carport and depress the clutch a couple of dozen times then look for leaking fliud. Good luck
AnswerID: 5959

Reply By: Grazza - Friday, Aug 23, 2002 at 00:00

Friday, Aug 23, 2002 at 00:00
Thanks, Yeah I have given that a go but its such a small volume of liquid that I am finding it very hard to find the source...what I need is some glow in the dark clutch fluid!!!
AnswerID: 5961

Reply By: voxson - Friday, Aug 23, 2002 at 00:00

Friday, Aug 23, 2002 at 00:00
Hi. I owned an 88Mav a while back with a similar prob and it turned out to be the slave cylinder. ( underneath car )... I bought a new one for about $120 and problem solvered.
AnswerID: 5979

Follow Up By: Royce - Saturday, Aug 24, 2002 at 00:00

Saturday, Aug 24, 2002 at 00:00
No drips on carport floor cos that's not where you're pumping the brakes. Slave cylinder probably. Easy to fit yourself. Cheers Royce
0
FollowupID: 2613

Sponsored Links

Popular Products (13)