My lc 79 turbo is fixed..ages ago now

Submitted: Tuesday, Jan 18, 2005 at 11:56
ThreadID: 19555 Views:1817 Replies:2 FollowUps:1
This Thread has been Archived
HI All

un update on my LC 79turbo ute that would not start....kick over..but not kick into life.

Toyotas didnt know for about 2 days wot was wrong...When they did
"suspect" wot was wrong they said that my part didnt exist.....anywhere in Australia

....finally about 7 days later....they said I get 50/50 warranty because one battery had developed a hole..the acid had leaked and affected the fusable link...so they replaced 1 battery, fusable link and I requested they replace the other 2nd battery which was on it way out..so all up..$200 bucks to fix it...i just pay it and forget it!

cheers
Back Expand Un-Read 0 Moderator

Reply By: Member - Sparkie (QLD) - Tuesday, Jan 18, 2005 at 15:06

Tuesday, Jan 18, 2005 at 15:06
But does it work now????????????????????????

Sparkie(IE not Y) ;-)
AnswerID: 93783

Follow Up By: bill - Tuesday, Jan 18, 2005 at 16:29

Tuesday, Jan 18, 2005 at 16:29
Oh yeah....back in fine form....just dreaming of a dtronic and
an intercooler from cooma diesel....hmmmmmm
0
FollowupID: 352759

Reply By: Member - Phil G (SA) - Wednesday, Jan 19, 2005 at 12:04

Wednesday, Jan 19, 2005 at 12:04
So the problem was a fusible link.

I'm guessing they got moved away from their origional position when the second battery was installed. They hang off the battery post, which is not ideal. I have supported mine with cable ties at each end of the links, so they aren't affected by corrugations etc

Cheers
Phil
AnswerID: 93908

Sponsored Links

Popular Products (13)