Sluggish 2.8TD Patrol

Submitted: Thursday, Jan 20, 2005 at 21:07
ThreadID: 19630 Views:2666 Replies:5 FollowUps:2
This Thread has been Archived
I'm hoping someone out there in fourbyLand can help me,
I own a GU Patrol with a 2.8TD, which, to you toyota guys hasn't given me any trouble until now. I started it up one afternoon at work to head for home when the motor farted and spluttered with belowing bluey-white smoke out the backend. When I finally decided to drive home it totally lacked power as if there was no boost from the turbo while also idling a little rough. I took it to a deisel mechanic and had all the usual tests done without connecting it to a diagnostic computer. Fuel line flush, fuel pump check, etc. Someone asked if the airflow sensor was clean, so I pulled it out and cleaned it with a computer parts cleaner which made a little difference. so my question is: could this sensor cause the engine to do as I described, or should I be taking it to nissan for diagnostic tests?

Signed, Unsure!
Back Expand Un-Read 0 Moderator

Reply By: sevo - Thursday, Jan 20, 2005 at 21:58

Thursday, Jan 20, 2005 at 21:58
I would recommend taking to Nissan dealer, will save you time in the long run.
AnswerID: 94167

Follow Up By: Selastic Man - Friday, Jan 21, 2005 at 08:54

Friday, Jan 21, 2005 at 08:54
Thanks sevo, do you have an idea what the problem could be (out of interest)?
0
FollowupID: 353214

Reply By: Member - Chrispy (NSW) - Friday, Jan 21, 2005 at 09:18

Friday, Jan 21, 2005 at 09:18
Not sure about the 2.8, but I presume it has a "limp-home" mode. Might you be in it?
AnswerID: 94219

Follow Up By: Selastic Man - Friday, Jan 21, 2005 at 09:29

Friday, Jan 21, 2005 at 09:29
I'm taking it to nissan, let them sort it out.
0
FollowupID: 353216

Reply By: sevo - Friday, Jan 21, 2005 at 14:40

Friday, Jan 21, 2005 at 14:40
Gday,
Could be a few things ,possible Needle lift sensor (No1 injector), right through to a pump failure.and all thats in between.Consult 2 will help narrow it down
cheers Sevo
AnswerID: 94277

Reply By: Patrol22 (Queanbeyan - Friday, Jan 21, 2005 at 15:40

Friday, Jan 21, 2005 at 15:40
Selastic Man - could you please let us know what the problem is when you have it sorted. I haven't had the problem.......................yet, but I do have a GU2.8tdi

Cheers
Pete
AnswerID: 94284

Reply By: Shep - Monday, Jan 24, 2005 at 15:44

Monday, Jan 24, 2005 at 15:44
Selastic Man , I heard through the grape vine you rinse the sensors out in Coca-Cola , Coke adds life 8-)
AnswerID: 94670

Sponsored Links

Popular Products (13)