GU fuel transfer pump

Submitted: Sunday, Feb 27, 2005 at 15:27
ThreadID: 20824 Views:1530 Replies:4 FollowUps:4
This Thread has been Archived
G'day peoples,

Have only had the 98 2.8 GU for a couple of months,about a month ago I filled the sub tank and went to pump it across and all I got was the "sub tank"light on the dash come on. 4by place in slacks ck tells me that transfer pump problems in this model is quite common and puts a new pump on. The sub tank light stayed on, they tell me that the others they did had to be driven for a while and let the main tank run down before the computer recognizes the new pump and kicks in, tried this for 3 tanks with less than 10lt left in every time with no luck.
Next idea came from a workshop manager for nissan, they disconnect the battery for 20 min and upon reconnection the computer reboots and light should stay out, and problem solved, tried this, problem not solved.
Computer workshop manual at a different mechanic states the same thing but to leave disconnected for a 24hr period. Nope that don't work either.
Auto leccy tells me there is only 3 volts at the pump end of the wiring, not sure if this is normal whilst pump is inactive, seemed to think the problem is at switch or further along the line, but wasn't real sure.
Am having trouble finding someone with previous repair experience in this area.
Does anybody know if there is a relay for the pump somewhere, I can't find one, or any other ideas would be much appreciated.
If all else fails I will disconnect the pump from the computer, unplug the light and manualize the whole system with a switch to turn on to pump across,and turn off when finished, like the good old K.I.S.S days.

Avagoodn
Pezza
Back Expand Un-Read 0 Moderator

Reply By: hl - Sunday, Feb 27, 2005 at 17:08

Sunday, Feb 27, 2005 at 17:08
Hi,
You do realize it takes quite a long time to transfer fuel, like 1/2 hour?
You can hear the pump click if you turn the ignition on without starting the engine and then press the tranfer switch. Provided your main is not full, in which case the pump won't start.
It will also run for a few seconds every time the engine is started when the main tank is not full, so, if you do lots of short runs, you will notice the sub will slowly empty even if you don't press the transfer switch.
cheers
AnswerID: 100375

Follow Up By: Pezza - Monday, Feb 28, 2005 at 18:19

Monday, Feb 28, 2005 at 18:19
Hi hl,
Yes I realize it takes a while to transfer, had twin tanks on a forerunner.
problem is pump will not run, had my hand on it ( the pump that is! ) while the missus started the car and also pushed transfer button, nothing happened.
Also forgot to mention that the green light on the button will not come on at all.

thanks
Pezza.
0
FollowupID: 358698

Reply By: jenkie - Sunday, Feb 27, 2005 at 19:11

Sunday, Feb 27, 2005 at 19:11
Brother in law has had this same problem a couple of years ago. From memory it went back to Motorama as it was under used car warranty at the time. They fixed it up. worked ok on drive home then stopped again. Took it back and they kept the car for a couple of days and took the car to Nissan Moorooka. They fixed it but we cant remember what the fault was. We think they put in a new computer chip and that something was wrong with the earth connection. Soon after this the alternator sh.t itself and a couple of people wonder if it was the alternator that caused the problem all along. Low voltage may have been the problem. They have not had any problem since.

When the sub tank first had its problem the car was on Fraser Island. Two mechanics under the car bypassing the wiring - one an auto elec, so that it pumped to the main tank. They had an intgerested vistor watching them about 3 feet away lying on the gound was a dingo which just watched with interest.
Jenkie

Member
My Profile  Send Message

AnswerID: 100385

Follow Up By: Pezza - Monday, Feb 28, 2005 at 18:23

Monday, Feb 28, 2005 at 18:23
G'day Jenkie
Had the voltage output checked when the twin batteries were fitted, it works fine. So not that either I'm afraid.

Thanks
Pezza
0
FollowupID: 358700

Reply By: Member - Roachie (SA) - Monday, Feb 28, 2005 at 16:13

Monday, Feb 28, 2005 at 16:13
Seem to recall this matter has been raised on here b4.

From memory the problem stemmed from poor earth of the pump, but also remember something to do with the vehicles having been fitted with either a turbo timer and/or an aftermarket cruise control system. Does yours have either of those add-ons?

Touch wood, my 4.2TD has done 150,000klm and I've never had a problem with my transfer pump; but I do use it every month or so; maybe that's what they need....regular use.

Good luck

Roachie
AnswerID: 100519

Follow Up By: Pezza - Monday, Feb 28, 2005 at 18:40

Monday, Feb 28, 2005 at 18:40
HI Raochie,
I had checked the archives before posting but couldn't find anything on this particular subject that could help me, ( maybe I missed some by not putting in the correct words ) The earthing problem is the first thing we checked even before replacing the pump, have neither of the accessories you mentioned fitted as yet and the new pump should have solved any lack of use problems.
You can see why I'm at a loss here, am starting to run out of hair and will have to give the brain an oil change from over use again..... now where's that oil can with the XXXX on it???

Thanks
Pezza
0
FollowupID: 358704

Follow Up By: Member - Roachie (SA) - Monday, Feb 28, 2005 at 20:30

Monday, Feb 28, 2005 at 20:30
Pezza...

I reckon at this stage, if it was mine, I'd seriously go with the idea of fitting a manual switch; or at least rewire the existing switch on the dash, so that it simply turns the pump on via a relay if necessary. I'm not sure, but would think this should be fairly straight forward, the hardest part would be tracing the wires/getting to the back of the switch etc. Every time I use my transfer pump, I always seem to keep an eye on the small green light in the switch, just so I know when the transfer has been completed. It would not be difficult to monitor and switch it off manually when you see the sub tank is empty.

Good luck

Roachie
0
FollowupID: 358723

Reply By: Member - Errol (York WA) - Monday, Feb 28, 2005 at 19:05

Monday, Feb 28, 2005 at 19:05
G,Day Pezza . There a post about this prob , but some time back . I know , becouse replied to it . Try pulling the fuse at dash and cleaning the fuse blades . This fixed the prob for me . So saying , my mate here in town has the same prob , and this didn't work for him , so he's going down the same track as you . Cheers
AnswerID: 100550

Sponsored Links

Popular Products (14)