sportrak map GPS

Submitted: Saturday, Jun 04, 2005 at 11:05
ThreadID: 23581 Views:1425 Replies:2 FollowUps:1
This Thread has been Archived
I am trying to load Discover Aus onto a Sportrak Map GPS, I think that the problem is that my GPS is a 3.02 version (and Discover Aus requires it to be 4.0).
Is there a solution to this problem ?
Back Expand Un-Read 0 Moderator

Reply By: Mad Dog (Australia) - Saturday, Jun 04, 2005 at 11:23

Saturday, Jun 04, 2005 at 11:23
Update your firmware from the Magellan site. The latest revision is 5.34

http://www.magellangps.com/en/support/software.asp
AnswerID: 114333

Reply By: pippa - Saturday, Jun 04, 2005 at 13:06

Saturday, Jun 04, 2005 at 13:06
Thanks for the help. It worked a treat.
AnswerID: 114340

Follow Up By: Mad Dog (Australia) - Saturday, Jun 04, 2005 at 17:58

Saturday, Jun 04, 2005 at 17:58
My pleasure
0
FollowupID: 370302

Sponsored Links

Popular Products (14)