GU 2.8

Submitted: Thursday, Jul 21, 2005 at 09:48
ThreadID: 24925 Views:1803 Replies:4 FollowUps:1
This Thread has been Archived
My dad's got a 2.8 turbo GU with some starting probs. First thing in the morning it starts no worries. Later when the engine's warm, you have to wind it over for up to 20 seconds before it'll fire up, bellowing half burnt diesel everywhere and knocking. All the instrumentation tells us that the glow is working properly but it don't start well at all. Just wondering if anybody's seen this sort of thing before as our local mechanic seems a bit scared of it! Cheers.........
Back Expand Un-Read 0 Moderator

Reply By: hl - Thursday, Jul 21, 2005 at 10:00

Thursday, Jul 21, 2005 at 10:00
There is a mod for that.
Call Motsons
Cheers
AnswerID: 121419

Follow Up By: sevo - Thursday, Jul 21, 2005 at 11:28

Thursday, Jul 21, 2005 at 11:28
gday,
Replacement timing cover on injector pump is required
Part NO.09621-8090AU also oring part no 16826-v0700
this with fix your concern
cheers Sevo
0
FollowupID: 376543

Reply By: luigi - Thursday, Jul 21, 2005 at 15:18

Thursday, Jul 21, 2005 at 15:18
I had a similar problem with my 2.8 Turbo although mine is a '97 model GQ.
My fix was a new battery.

Car would start fine in the morning but once it was warmed up it needed a few goes, sometimes like you said 15 to 20 seconds, and then finally starting with an embarrassing cloud of smoke.

A new battery like I said worked for me, its worth a try. ( Try borrowing from someone first to see if it works)

Hope this helps

Cheers!
AnswerID: 121450

Reply By: Happy GU Owner - Thursday, Jul 21, 2005 at 16:14

Thursday, Jul 21, 2005 at 16:14
Bullwinkle,

I am sure that people that have had this problem were all able to fix the problem by adding a shim at the injector pump.

Do a search through the Patrol4WD or the Nissan_GU_Patrol forum on Yahoo, and I am sure that you will find the fix for your problem.

Mic
AnswerID: 121459

Reply By: rolande- Thursday, Jul 21, 2005 at 21:09

Thursday, Jul 21, 2005 at 21:09
Until you are able to arrange for the Motson's repair, leave the vehicle on ignition for a further 5 seconds AFTER the glow plug light has gone out and it will start easier

Rolande
AnswerID: 121506

Sponsored Links

Popular Products (13)