hj 60 chattering relays

Submitted: Thursday, Feb 16, 2006 at 21:03
ThreadID: 30852 Views:1118 Replies:3 FollowUps:0
This Thread has been Archived
Hi Guys,Mymate has a HJ60 which has recently started chattering the starter and glow relays,i thought it may have had a bad earth to both relays so i gave them each an independant return and it fixed it (or so i thought!!)it certainly stopped them chattering at idle but when he left they started again!.it now only does it when the revs are brought up above 1000 odd RPM.i seem to remember someone else having this problem but cant find post nor can remember what the eventual outcome of the fix was.any help would be appreciated as them chattering while driving sends him nuts!Paul
Back Expand Un-Read 0 Moderator

Reply By: Member - Davoe (Widgiemooltha) - Thursday, Feb 16, 2006 at 21:16

Thursday, Feb 16, 2006 at 21:16
Yep heard ity before. It was closley followed by the failure of every esential electrical system. Fuel control module, glow plg control , edic motor - cost me 000s
AnswerID: 155445

Reply By: Footloose - Thursday, Feb 16, 2006 at 21:33

Thursday, Feb 16, 2006 at 21:33
Check battery voltage, and voltage regulator ??
AnswerID: 155448

Reply By: ToyMotor - Friday, Feb 17, 2006 at 22:40

Friday, Feb 17, 2006 at 22:40
My old 60 used to do this, about twice a year in the ten years I had it. It never got any worse in the 200,000 odd kays I did in it - I guess I was lucky!

Cheers
AnswerID: 155651

Sponsored Links

Popular Products (13)