new engine block for my patrol

Submitted: Saturday, Mar 04, 2006 at 11:26
ThreadID: 31407 Views:2211 Replies:6 FollowUps:7
This Thread has been Archived
Nissan just gave me my car back, after almost 40 days of waiting without a car.

the new block seems to work fine, the only difference I feel that the engine runs
more quietly, you can barely listen to it even at high rps , I dont know if thats normal?
well, I wait and see if this one goes bang probably exchanging it for a pathfinder td2.5
also what guarantee did nissan give after engine failure?
the person that gave me the engine told me that the guarantee is until 100000kms
and my car has 65000 I only have 35ooo left? in my point of view it has to be 100000 additional only to the engine?
Back Expand Un-Read 0 Moderator

Reply By: Member - Charlie M (SA) - Saturday, Mar 04, 2006 at 13:10

Saturday, Mar 04, 2006 at 13:10
It will be interesting to see how long the 2.5 td lasts after the 3.0ltr episode.
Cheers
Charlie
AnswerID: 158538

Follow Up By: Dave Thomson - Saturday, Mar 04, 2006 at 15:31

Saturday, Mar 04, 2006 at 15:31
Hi Charlie, sorry mate I missed your original thread, what happened to you original car , what yearwas it ? and did you have to pay much yourself ? also, is it a 2006 model engine they stuck in it ?
regards,
Dave
0
FollowupID: 413027

Follow Up By: jorgejhandal - Sunday, Mar 05, 2006 at 04:36

Sunday, Mar 05, 2006 at 04:36
I think its a better engine, this engine has been used for a long time in spain, (the old version with top mount intercooler) and never failed
the terrano used this engine for a long time, and the firefighters here in honduras have them since the huricane mitch and they have not failed yet
which is a miracle because here the government vehicles especially police congress firefighters, they destroy the vehicles.
they have had whole fleets of hilux, frontiers, mitsubichi ,prados and they totaly end up destroyed, crashed .
my uncle that works in crongress was assigned a prado with 1 year of use and it had to be taken to get the transmision gearbox, new seats, new rear diff etc( and was only used by a congress man so this is an example of government abuse
so I think this engine would be good
0
FollowupID: 413152

Reply By: Member - 'Lucy' - Saturday, Mar 04, 2006 at 15:51

Saturday, Mar 04, 2006 at 15:51
Your guarantee = until you walk out the door.
AnswerID: 158566

Reply By: ACDC - Saturday, Mar 04, 2006 at 16:38

Saturday, Mar 04, 2006 at 16:38
Did they fix the reason for the failure in the first place?
AnswerID: 158571

Follow Up By: Bonz (Vic) - Saturday, Mar 04, 2006 at 18:14

Saturday, Mar 04, 2006 at 18:14
It was a failed Toyota part
.
Time is an illusion produced by the passage of history
.

Lifetime Member
My Profile  My Blog  My Position  Send Message
Moderator

0
FollowupID: 413065

Follow Up By: jorgejhandal - Sunday, Mar 05, 2006 at 04:28

Sunday, Mar 05, 2006 at 04:28
no they just replaced the engine block, left everything else as it was, they told me that they had never seen this problem, but I dont believe it because I have a friend that had similar problem after 3 months of having it and it was almost the same year,
(newer than mine)
and the others I heard with 160000kms and 115000 better luck than me (well Im lucky because it failed under warranty)
0
FollowupID: 413151

Follow Up By: ACDC - Sunday, Mar 05, 2006 at 12:47

Sunday, Mar 05, 2006 at 12:47
Any symptoms before it failed! blowing off cooler hoses or flat spots etc poor fuel economy..?
0
FollowupID: 413184

Follow Up By: Truckster (Vic) - Sunday, Mar 05, 2006 at 17:12

Sunday, Mar 05, 2006 at 17:12
"they told me that they had never seen this problem"

Search this site, Outerlimits, The patrol forums/ GU/GQ/Patrol4wd/etc, Overlander, 4wd mthly, etc print out about 1000 dead 3.0 stories, and hand them to the fool you wre dealing with lol.
0
FollowupID: 413224

Follow Up By: jorgejhandal - Monday, Mar 06, 2006 at 11:01

Monday, Mar 06, 2006 at 11:01
yes the intercooler hose popped off at about 3000 kms, intercooler leaked and dealer didnt substitute it until 55000 kms(started leaking at about 10000kms
engine bounced at idle speed when stopped in a stoplight or just plain sitting there with the engine on.
once in a while white smoke came out of the exhaust permanently at idle too.
several times had ckeck engine with air mass sensor error
0
FollowupID: 413371

Reply By: Truckster (Vic) - Saturday, Mar 04, 2006 at 17:45

Saturday, Mar 04, 2006 at 17:45
Trade it in now while it hasnt cost you $15,000 for a rebuild.
AnswerID: 158588

Reply By: Member - Charlie M (SA) - Monday, Mar 06, 2006 at 19:03

Monday, Mar 06, 2006 at 19:03
Im glad I bought a prado and not a patrol
Cheers
Charlie
AnswerID: 158935

Reply By: Outbacktourer - Monday, Mar 06, 2006 at 22:03

Monday, Mar 06, 2006 at 22:03
Can't believe the above two posts. It takes a certain personality to revel in someone else's misfortune. Shame on you.
AnswerID: 158986

Sponsored Links

Popular Products (13)