Patrol Y60 wiper electrical problem

Submitted: Wednesday, Apr 12, 2006 at 07:33
ThreadID: 32813 Views:3800 Replies:6 FollowUps:2
This Thread has been Archived
HI all

I just bought a '93 Patrol GR and the rear wiper doesn't work. The squirter does though. Also, applying power directly to the motor shows the motor works ok. The wiring is not very conventional , there appears to be some sort of logic control etc, only small 'signal' wires seem to come from the switch. There is no power present at the motor. (But the intermittent rear wipe box under the hood has power) . Is there a relay somewhere or fuse somewhere for this (checked the fuse in the main fusebox in the Right A-pillar its ok)

Anyone else had this problem? any help appreciated.
Back Expand Un-Read 0 Moderator

Reply By: Willem - Wednesday, Apr 12, 2006 at 07:57

Wednesday, Apr 12, 2006 at 07:57
I had a similar problem with the headlight dip stalk/switch. Searched till I was blue in the face checking all contatcs, wiring, lights, relays, fuses etc etc and eventually found it was the switch contact itself which is a sealed unit. Replaced it with used part from wreckers...$100...no choice(Melbourne). Nissan parts are as scarce as hens teeth and expensive too boot. My GQ is a RX which makes it even more scarce to find the right bits.
AnswerID: 166592

Reply By: WillDatsun - Wednesday, Apr 12, 2006 at 08:09

Wednesday, Apr 12, 2006 at 08:09
Thanks the switch was sort of sealed but i managed to get in it, and cleaned and reassembled, wasn;t the problem. no power getting to switch anyway, and thirdlly the motor is supposed to be live all the time, and the functions controlled by the grounds I believe. Most odd.
AnswerID: 166597

Reply By: cokeaddict - Wednesday, Apr 12, 2006 at 13:41

Wednesday, Apr 12, 2006 at 13:41
can fix ur problem in 3 words mate....
get a sparky !!
AnswerID: 166659

Reply By: techie - Wednesday, Apr 12, 2006 at 16:52

Wednesday, Apr 12, 2006 at 16:52
Wouldn't it be greate to have electrical diagrams of these vehicles avail on this (or some) website!
We can then peruse any problem presented by forumites with the relevent cct avail for diagnostics.
Many of you would have manuals which include electrics, why not scan these and make them avail to members as needed. Take a lot of guesswork out of things.

My E2000 van had a rear wiper prob - there was a connection after the wires went into the main chassis from the back tailgate and they were corroded clean through. Replaced the plug/socket - worked like a charm.
Techie.
AnswerID: 166718

Follow Up By: Shaker - Wednesday, Apr 12, 2006 at 16:58

Wednesday, Apr 12, 2006 at 16:58
If they had wiring daigrams, couldn't they peruse them themselves?
0
FollowupID: 421632

Reply By: WillDatsun - Wednesday, Apr 12, 2006 at 20:08

Wednesday, Apr 12, 2006 at 20:08
im good with electrics (i have wired up nissan EFI engines into other cars etc) so i wont get a 'sparky' and i dont know any 'sparkys' that would know enough to know more than i do about this fault , this vehicle is rare where I am in England and I'm posting on here in the hope that somoneone has had the same problem.

I have a wiring diagram by the way, but it doesnt tell you everything
AnswerID: 166760

Follow Up By: techie - Friday, Apr 14, 2006 at 21:43

Friday, Apr 14, 2006 at 21:43
possible to eMail wiring diagram as attach?
would be interested.
DonkAtTechieDotCom.
Techie
0
FollowupID: 422078

Reply By: WillDatsun - Saturday, Apr 15, 2006 at 22:51

Saturday, Apr 15, 2006 at 22:51
i only have the cheap Haynes book (which is very disappointing) i dont have a scanner but could try a digi pic
AnswerID: 167188

Sponsored Links

Popular Products (13)