'92 hilux diesel ignition fault

Submitted: Friday, Apr 14, 2006 at 05:19
ThreadID: 32879 Views:1503 Replies:3 FollowUps:2
This Thread has been Archived
My well used trusty hilux has develop an ignition fault-which is not surprizing as it has been dumped into a lot of deep water crossings throughout its life.The fault been on cold startup there is no ignition lights on the dash-hence the glow plugs don't work.After driving for a while, I can stop and when I go to restart ,wham, all the ignition lights work, including the glow plugs( which are not needed when the engine is hot).Can someone give me an idea on where to look for the fault before I start pulling the electrics apart???Cheers
Back Expand Un-Read 0 Moderator

Reply By: mik_wright - Friday, Apr 14, 2006 at 08:48

Friday, Apr 14, 2006 at 08:48
Check the electrical connectors in the engine bay especially from the alternator. The plastic tends to wear out on some of the clips and does not hold the wire on as well as it should. Good luck, it is always difficult to find an intermittant fault...
AnswerID: 166985

Follow Up By: browndog01 - Friday, Apr 14, 2006 at 08:56

Friday, Apr 14, 2006 at 08:56
thank mik..i shall try that, and from there i guess i'll just be following wires and pulling the dash to bits
0
FollowupID: 421991

Reply By: Wisey (NSW) - Friday, Apr 14, 2006 at 12:41

Friday, Apr 14, 2006 at 12:41
Browndog

I had a similar prob last wk. A 10amp fuse in the engine bay fuse box had blown and no dash or park lights, due to a short in the tail light.
Clean up box and fuses and spray with a lanolin base spray, eg Lanotec. Use on all lectrics + more

Andy
AnswerID: 167006

Reply By: Member - Jeff M (WA) - Friday, Apr 14, 2006 at 19:05

Friday, Apr 14, 2006 at 19:05
Does the speedo and or tacho work when the lights are not on? They are generally powered from the same fuse. (on mine it is anyway). If so then I'd probally do as the others have suggested and pull the fuse out and look for corrosion. Spray with CRC or what ever you're favourate poison is and see what happenes. But yeah, I'd probally do all the under bonnet electrics, as that's probally a sign of things to come.
AnswerID: 167045

Follow Up By: browndog01 - Saturday, Apr 15, 2006 at 06:45

Saturday, Apr 15, 2006 at 06:45
Jeff,
Yes the speedo and tacho work so does the park brake light , but not the others- until the engine has warmed up, occassionally the lights do come on when it cold.I really hate tracking faults like this, and I'll give your suggestion a go.
Anyone want to come to FNQ and do it for me??

Cheers
0
FollowupID: 422115

Sponsored Links

Popular Products (13)