coleman magic.

Submitted: Wednesday, Apr 19, 2006 at 21:08
ThreadID: 33057 Views:2044 Replies:5 FollowUps:8
This Thread has been Archived
howdy all.
hope you all had a good easter. well went out canungra camping with the coleman hot water system and they are fantasic until the battery goes flat.. do you think i could find the cig lighter charger for it. no where to be found in the box. lucky it was monday and were coming home anyway. rung Anaconda up today and told them there was no charger and they said we have one here if you want to come and get it. ways i goes and they open up little side part and wha la. didn't i feel like a dill. never thought of looking over the appliance. wasn't it a great weekend weather wise that is.
peter d
Back Expand Un-Read 0 Moderator

Reply By: Brew69(SA) - Wednesday, Apr 19, 2006 at 21:13

Wednesday, Apr 19, 2006 at 21:13
hahaha i know what u are talking about. I was packing mine back into the box to return to Ray's when i spotted its hiding place lol. Nothing to tell u where it hides.
AnswerID: 167910

Follow Up By: peter d - Wednesday, Apr 19, 2006 at 21:18

Wednesday, Apr 19, 2006 at 21:18
hi Brew, what did you think of it apart from that. i found them ( well the wife did anyway) to be bloody marvellous. had dozen showers before it went flat and only half a can of gas.
peter d
0
FollowupID: 423155

Follow Up By: Sand Man (SA) - Wednesday, Apr 19, 2006 at 21:32

Wednesday, Apr 19, 2006 at 21:32
A dozen showers over a four day Easter break????

Or perhaps we're missing some other relevant information:-)
Bill


I'm diagonally parked in a parallel Universe!

Member
My Profile  My Blog  My Position  Send Message

0
FollowupID: 423159

Follow Up By: Brew69(SA) - Wednesday, Apr 19, 2006 at 21:47

Wednesday, Apr 19, 2006 at 21:47
Not used it yet lol
0
FollowupID: 423170

Follow Up By: keepkampen - Thursday, Apr 20, 2006 at 19:16

Thursday, Apr 20, 2006 at 19:16
hi sandman,
two off us and a new toy so twice a day. but my last one was ccccold on monday morning. No it was bloody freezing on monday morning.
peter
0
FollowupID: 423393

Reply By: Member - Norm C (QLD) - Wednesday, Apr 19, 2006 at 21:42

Wednesday, Apr 19, 2006 at 21:42
So where at Canungra did you camp Peter?
AnswerID: 167923

Follow Up By: keepkampen - Thursday, Apr 20, 2006 at 19:04

Thursday, Apr 20, 2006 at 19:04
hi norm, camped at james sharp park just pass the army camp on the right. great spot and peaceful it was to. except the odd jenny .
peter .
0
FollowupID: 423388

Reply By: Haza - Wednesday, Apr 19, 2006 at 21:43

Wednesday, Apr 19, 2006 at 21:43
It takes a real man to admit his mistakes, good on ya, had a good laugh.
AnswerID: 167924

Reply By: Happy Little Camper - Wednesday, Apr 19, 2006 at 22:10

Wednesday, Apr 19, 2006 at 22:10
G'day Peter

We also saw the response to previous posts regarding the Coleman Hot Water on Demand.

We bought a Primus Hot Water Heater 3 years ago, and have never got it to work properly even after returning it to Primus for several "modifications". We decided that if it didn't work properly this Easter we were going to give up and get the Coleman, which it didn't so we did.

Anyway, we must be jinxed cause our new Coleman packed it in after only 3 days. While it was working it was great I might add. Plenty of Battery Charge, Plenty of Gas, no error lights, but it just refused to ignight. We ended up heating water on the stove and using the colemans pump to feed the shower, as we had done with the Primus for the last 2 years running. I need to calm down a bit more b4 I pull it out of the box and get it fixed (if we can't return it).

Driv'n Ivan & HLC

AnswerID: 167941

Follow Up By: keepkampen - Thursday, Apr 20, 2006 at 19:10

Thursday, Apr 20, 2006 at 19:10
hi there Ivan, have you tryed to charge it up anyway as mine light didn't come on either. but once i charged it goes like a dream. they told me to run it for about 15/20 minutes and give it a good work out. so i did and it heated a bucket of cold water to hot in about 10 minutes. hpoe this helps.
peter
0
FollowupID: 423391

Follow Up By: Member - Happy Little Camper - Thursday, Apr 20, 2006 at 20:05

Thursday, Apr 20, 2006 at 20:05
Peter,

I had it on charge overnight prior to the day it packed it in. I doubt very much the battery was flat because you could hear a good strong click-click-click as it was trying to ignite the gas. I found a small blowout in the LPG hose but it must have been a very small leak because I could not smell any gas. My guess is maybe a small fragment of rubber has blocked the gas jets.

Anyway I returned it to BCF tonight but they wouldn't give my money back without testing the fault first. I will have to wait for them to test report back.

Regards
Driv'n Ivan
0
FollowupID: 423416

Reply By: keepkampen - Thursday, Apr 20, 2006 at 19:12

Thursday, Apr 20, 2006 at 19:12
bye the way i have a new name now as for some reason i couldn't log on last night or today so reregistered..
peter
AnswerID: 168137

Follow Up By: Brew69(SA) - Thursday, Apr 20, 2006 at 20:18

Thursday, Apr 20, 2006 at 20:18
ok clears up my confusion
0
FollowupID: 423418

Sponsored Links

Popular Products (13)