no spark when trying to start the caravan fridge on gas

Submitted: Sunday, Feb 24, 2008 at 14:14
ThreadID: 54874 Views:11531 Replies:6 FollowUps:1
This Thread has been Archived
hi, we have an electrolux RM4400 three way fridge in the van and in the past it has ignited fine, but today going over things in the van found that it's lost it's spark, we did get it to click twice and nothing since, and yes there is gas in the bottle. is there a spot that would need a good clean and we are not to sure where the spark arcs out to.
so if you have any thoughts on the matter please let me know from Chris.
Back Expand Un-Read 0 Moderator

Reply By: gerrybhoy - Sunday, Feb 24, 2008 at 15:29

Sunday, Feb 24, 2008 at 15:29
g'day, remove access panel and have a look around the main burner on the bottom rear of the fridge,you have to remove a small metal cover.the burner is about the same diameter of your finger.check your'e getting a spark arcing onto or around the burner,if not the ignition lead is earthing elsewhere or you have a faulty ignitor,also checkburner is not blocked with dust and isolator valve is in on position.Is your hotplate working?.
AnswerID: 289120

Follow Up By: DIO - Sunday, Feb 24, 2008 at 16:17

Sunday, Feb 24, 2008 at 16:17
I find that it is always a good idea to light a burner/hotplate before attempting to ignite fridge - particularly if is hasn't been running for a while. It ensures that you have gas flowing from bottle and lines are full.
0
FollowupID: 554458

Reply By: Member - Graham H (QLD) - Sunday, Feb 24, 2008 at 15:33

Sunday, Feb 24, 2008 at 15:33
have a look here

http://www.aroundoz.com/a_clinic_archive/refrigeration/electrolux_fridges_avan.htm

Google it Amazing what u ill find
Cheers
AnswerID: 289121

Reply By: gonebush SA - Sunday, Feb 24, 2008 at 18:14

Sunday, Feb 24, 2008 at 18:14
hi, yes the van was level and the stove is working, there is gas there as we can light the fridge with a lighter from the back it just seems to be a problem with the igniter not working right. Chris
AnswerID: 289138

Reply By: disco driver - Sunday, Feb 24, 2008 at 19:34

Sunday, Feb 24, 2008 at 19:34
The Piezo type igniters, (those push button or twist things that create the spark), have been known to sh*t themselves on occasions.
They should be available as a replacement part from any good caravan parts place (Camec or similar).
Failing that, Google is your friend, search for electrolux and go from there.

Disco.
AnswerID: 289165

Reply By: Member - kevin Y (SA) - Sunday, Feb 24, 2008 at 20:19

Sunday, Feb 24, 2008 at 20:19
got the same problem in my that i'm restoring . fridge worked fine on 240 volt .but not on 12 volt or gas ----checked out google with --search -electrolux lpg refrigeration ----- found the problem solver page --- mine is no power at starter-----had further look as penny dropped ----my lights aren't working in van iether---examination ---someone cut the bloody wires underneath van body ----at least the fridge lit with a match
AnswerID: 289180

Reply By: oldtrack123 - Sunday, Feb 24, 2008 at 22:06

Sunday, Feb 24, 2008 at 22:06
Hi,if the igniter does not sound as before then it is probably faulty.
have you checked to make SUREl there is no soot flakes shorting the spark gap,even a whisker can short the spark
AnswerID: 289213

Sponsored Links

Popular Products (14)