Temp gauge not working

Submitted: Monday, Feb 25, 2008 at 22:45
ThreadID: 54932 Views:1517 Replies:3 FollowUps:3
This Thread has been Archived
Year i know, this is off topic, but I will ask anyway.
I have an old tractor, a Chamberlain with a 4 cyl Perkins desiel. It was missing all it's instruments so i bought a cheap set of gauges from the local Autobarn. Water temp, oil pressure & ammeter.
Oil pressure works, ammeter might if i ever conect the alternator.
Water sender would not screw into the block, I had do use 2 adapters & a through conect to adapt the sender unit into the block. temp gauge did not move, I treid bleeding the sender thinking I had an air lock, no joy.
I then bought a genuine temp gauge from a tractor sales. I tried this gauge by putting the sender in hot water, it worked fine. This sender screwed straight into the block without any of the adapters. BUT this gauge does not move either.
Anyone got any suggestions?
I have only run the tractor for a max of 20 min at a time and don't work it hard but the gauge did not move off the cold position.
I have though that the thermostat might be missing, so water is always circulating and not getting hot, I have not checked this yet, any other suggestions?

from Marty.
Back Expand Un-Read 0 Moderator

Reply By: Martyn (WA) - Monday, Feb 25, 2008 at 23:21

Monday, Feb 25, 2008 at 23:21
I might be wrong here but if you earth out the connection of the gauge at the sender unit if you have someone watching with the ignition on I think the gauge show go full scale, best to have someone watching the gauge so it doesn't go full scale, I think the gauge gets damaged if you hold the connection on past full scale. I know this works with a fuel tank sender unit and an oil pressure switch, not sure about temp. You could run a live straight from the live on the battery to the temp send connection that would make it move..........
Keep the shiny side up

Lifetime Member
My Profile  My Blog  Send Message

AnswerID: 289399

Follow Up By: MartyB - Tuesday, Feb 26, 2008 at 09:47

Tuesday, Feb 26, 2008 at 09:47
Hi Martyn,
I forgot to mention it is a mechanical gauge, not electrical, so this wouldn't be the problem.
Thanks for the reply.
FollowupID: 554740

Reply By: Member - barry F (NSW) - Tuesday, Feb 26, 2008 at 07:53

Tuesday, Feb 26, 2008 at 07:53
Hey Marty, I can't help you with your problem. But I used to to drive one in the mid sixties. The bloke I worked for back then farmed about 400 acres of wheat & bought a new Chamberlain to replace the worn out International.
They were a great tractor in their day and we were the envy of all the surrounding farms. Good luck.
AnswerID: 289420

Follow Up By: MartyB - Tuesday, Feb 26, 2008 at 22:14

Tuesday, Feb 26, 2008 at 22:14
Hi Barry,
Thanks for the reply.
Mine is actually a loader with a big front bucket. It is great for what I want it for. Moving some dirt, building jumps for the kids to ride over & cleaning up the old stumps & logs around my property.

FollowupID: 554876

Reply By: Mal58 - Tuesday, Feb 26, 2008 at 09:28

Tuesday, Feb 26, 2008 at 09:28
I wouldn't be surprised if the thermostat was missing or stuck open.

AnswerID: 289427

Follow Up By: MartyB - Tuesday, Feb 26, 2008 at 22:17

Tuesday, Feb 26, 2008 at 22:17
Hi Mal,
Yes this is my guess without looking. I will have a look one day soon. Because I don't work the motor hard i am a bit worried about causing extra wear to the motor by using it when it is not warmed up properly.

FollowupID: 554878

Sponsored Links