can you work this out,i cant [electrical]

Submitted: Wednesday, Mar 26, 2008 at 10:27
ThreadID: 55929 Views:1625 Replies:3 FollowUps:1
This Thread has been Archived
ot up this morning,went to start [hj60] ,bugga left my window down and a shower of rain got things a bit damp, ignition switch etc [RHD]
when i turned to glow position the corresponding lights were flashing [buzzing] and the solenoid to the buzz bar[round canister] was clicking in and out with a loud metalic buzzing. I gave it a wack with my nuckles and it stopped but the square glow plug relay started doing the same. the starter would not engage,with similar noises.
Meantime the taco,witch has never worked before [second hand vehicle] was sitting on 1000 rpm
Time for a cup of tea, and a call for help
Back Expand Un-Read 0 Moderator

Reply By: Footloose - Wednesday, Mar 26, 2008 at 10:30

Wednesday, Mar 26, 2008 at 10:30
Is your battery Ok ?
AnswerID: 294795

Reply By: Notso - Wednesday, Mar 26, 2008 at 11:01

Wednesday, Mar 26, 2008 at 11:01
Yep I reckon it's a flat or flattish battery
AnswerID: 294798

Reply By: dagwill - Wednesday, Mar 26, 2008 at 11:20

Wednesday, Mar 26, 2008 at 11:20
thanks for the fast response
i tracked it down to an earth prob.
i was imagining something far more complicated,and just didnt think to start at the beginning. THANKS
AnswerID: 294801

Follow Up By: Footloose - Wednesday, Mar 26, 2008 at 17:46

Wednesday, Mar 26, 2008 at 17:46
No worries...I used to own one and found that most of my problems were electrical :))
0
FollowupID: 560746

Sponsored Links

Popular Products (14)