Brake Pedal not returning home LC 100

Submitted: Wednesday, Apr 02, 2008 at 16:01
ThreadID: 56192 Views:1553 Replies:3 FollowUps:2
This Thread has been Archived
Hi, Is this a common problem.

On occasions the brake pedal does not return fully home therefore still applying a slight brake force. To remedy I have to put my foot under the pedal and pull up.


Regards

JD
Back Expand Un-Read 0 Moderator

Reply By: howesy - Wednesday, Apr 02, 2008 at 16:55

Wednesday, Apr 02, 2008 at 16:55
I have seen it before in a car and it may not be the same cause but in his the rubbers in the master cylinder were letting fluid past.
Undo the thing and pull it slightly away from the booster and see if its wet in the back of it. There should be enough flex in the lines so you dont have to undo them.
AnswerID: 296154

Reply By: Member - Phil G (SA) - Wednesday, Apr 02, 2008 at 17:12

Wednesday, Apr 02, 2008 at 17:12
Do you know what brake fluid has been used during the life of the vehicle?

It is possible that the seals in your brake master cylinder have swollen from the use of DOT4 fluid.
AnswerID: 296159

Follow Up By: Treading Lightly - Thursday, Apr 03, 2008 at 07:40

Thursday, Apr 03, 2008 at 07:40
Thanks for info Phil,

Toyota have done all service work, only done 70Ks.

JD
0
FollowupID: 562350

Reply By: Derek from Affordable Batteries & Radiators - Wednesday, Apr 02, 2008 at 20:57

Wednesday, Apr 02, 2008 at 20:57
It is a common problem.

Toyota have a spring recall and updated spring on the '99 to '01 series.

Not sure of the exact models or dates but had mine done about a year ago.
AnswerID: 296229

Follow Up By: Treading Lightly - Thursday, Apr 03, 2008 at 07:41

Thursday, Apr 03, 2008 at 07:41
Thanks Derek,

I will ring Toyota today and make inquires.

JD
0
FollowupID: 562351

Sponsored Links

Popular Products (14)