mitsubishi ABS & brakes issue

Submitted: Thursday, Apr 17, 2008 at 13:44
ThreadID: 56724 Views:1826 Replies:3 FollowUps:0
This Thread has been Archived
hi all i have a 2002 pajero petrol 3.5 ltr. i am having problems with the brake light and ABS light coming on , the brakes still work fine but not the ABS ( that realy does not bother me ) anyways have replaced the accumilator , checked all tollerances for the wiring ( ass per mitsubishi specs ) and all conuity , checked all the relays every thing . when the coputor is coded it comes up with a code no 55. which is pump motor circuit . now every thing works the motor is pumping as per norm every thing seems ok . to get the lights of i put the key in lock pump the pedal 40 times to empty accumilator , turn the key to on , alarm for brakes come on, pump comes on builds up pressur , arlarm goes off. start car all is fine till you use brakes a few times or use the ABS system , lights come back on what the ! . after sitting over night put key to on alarm comes on , pump starts pressure builds up all is fine ,then as desribed before all starts over again . please any mitsubishi techs got an answer.
Back Expand Un-Read 0 Moderator

Reply By: Member - Andrew (QLD) - Thursday, Apr 17, 2008 at 14:38

Thursday, Apr 17, 2008 at 14:38
I haven't got the answer sorry, however, isn't that alarm damn-right annoying? .... Drove with on for 5 hours once :-)

Andrew
AnswerID: 299018

Reply By: donks1 - Thursday, Apr 17, 2008 at 15:26

Thursday, Apr 17, 2008 at 15:26
G'day zacc

I just went through the mitsu service manual.

Sorry but everything is pointing to the Master/ Pump itself..

if all relays are ok, and there are no loose connections anywhere.
the abs computer is still throwing codes, so that is ok.

i can tell you that Mitsu has sold more than 40 in the last 12 months

@ $2200.00 though i'd have a real close look at all wiring first

donks
AnswerID: 299026

Reply By: zacc - Thursday, Apr 17, 2008 at 17:37

Thursday, Apr 17, 2008 at 17:37
yeh thanks for the guys , it is pointing towards the master cylinder. just replaced the accumilator ( lucky i could get it at trade) , checked all the wiring, even bled the brakes . at $2200 bucks i will certanly looking to see if i can put new seals in it . when the lights come on now before i start it i hit the brake a few times to release some pressure , turn the key on , alarm sounds , pump turns on pressure up lights off and away i go . i think i will be buying a $30.00 anchor and a snatch strap put it all on the wifes side and use that if all else fails . cheers
AnswerID: 299041

Sponsored Links

Popular Products (14)