GU4 Patrol Sub-Tank

Submitted: Wednesday, Jan 21, 2009 at 20:11
ThreadID: 65314 Views:3176 Replies:4 FollowUps:4
This Thread has been Archived
Hoping someone with more knowledge than me can shed some light to help troubleshoot this problem. The sub-tank lamp no longer illuminates when the button is pressed and no fuel transfer takes place. Have checked fuses/circuit breakers, etc and pulled the sub-tank switch apart to check the contacts, etc but still no go. Since the sub-tank switch has normally open contacts except when pressed I am assuming pressing the button activates a relay which turns the pump on until either the main tank is full or the sub-tank is empty. As I understand it, the main tank has a high level probe which prevents operation of the sub-tank until the main tank has sufficient space to accommodate the 32 litres in the sub-tank. Also I have noticed the the sub-tank lamp no longer flashes momentarily as it used to when the vehicle is first started and the sub-tank runs for a few seconds. I have checked for voltage at the sub-tank switch plug terminals but none is present. If someone has a wiring diagram or trouble-shooting procedure for this problem so I can go through the system in a methodical way to eliminate each possibility one by one it would be much appreciated.
Back Expand Un-Read 0 Moderator

Reply By: Patrolman Pat - Wednesday, Jan 21, 2009 at 20:23

Wednesday, Jan 21, 2009 at 20:23
It's a fairly common problem blown4by and it is usually an earthing problem. Fitting extra earths between the battery and chassis and engine block will probably solve the problem. Mine started to play up after i had the trailer wiring modified.
AnswerID: 345413

Follow Up By: Patrolman Pat - Wednesday, Jan 21, 2009 at 20:24

Wednesday, Jan 21, 2009 at 20:24
S Disconnect the battery for ten mins or so and it should reset the sub tank switch.
0
FollowupID: 613390

Follow Up By: Time - Wednesday, Jan 21, 2009 at 21:24

Wednesday, Jan 21, 2009 at 21:24
......agree, first stop is disconnect he battery, both if you have two, resets the subtank electrics, if that fails then start looking at the other $ options.
0
FollowupID: 613403

Reply By: Member - Mick O (VIC) - Wednesday, Jan 21, 2009 at 20:23

Wednesday, Jan 21, 2009 at 20:23
Blown4by,

(Damn that's an ominous handle you've got!). This seems to be an issue that gets a bit of airplay. Worst case scenario is that the pump is shot...in which case I hope you took the extended warranty option. A common fault in the GU's is earthing. There is an article specific to the fault in this months Australian 4x4 magazine (And I'm not promoting that rag at all). Check your earth straps. I would also recommend that you pop over to the PATROL WEBSITE and do a search there. You'll find a stack of posts in respect to this very issue.

Cheers Mick
''We knew from the experience of well-known travelers that the
trip would doubtless be attended with much hardship.''
Richard Maurice - 1903

Lifetime Member
My Profile  My Blog  Send Message

AnswerID: 345414

Follow Up By: blown4by - Thursday, Jan 22, 2009 at 16:04

Thursday, Jan 22, 2009 at 16:04
Mmmm. It refers to the fact it has a Turbo on it. Not that it has "blown up" - not yet anyway! Don't get the knockers started. Thanks I'll try that. Yeah those rags get a bit carried away in my opinion. All are Top Gear wannabee's. How they manage to write one view in one issue then one month later write completely the opposite view is beyond me. Maybe they just have short term memory loss.
0
FollowupID: 613489

Reply By: Michael ( Moss Vale NSW) - Wednesday, Jan 21, 2009 at 22:00

Wednesday, Jan 21, 2009 at 22:00
If you do a search about 12 months back, i posted the same problem. i spent $600 having Nissan diagnose the problem, you would think there is a data bank of known problems and you would think they have experienced the problem before,,,, Any way, after a few days at Nissan , they changed the sub tank pump and problem fixed.. They initially said it was a earthing problem, they put an earth on a 6mm bolt from the front coil tower to the battery earth, didnt clean the paint off, just shoved it under the bolt. i pushed on it and it was loose, I tried to tighten it , they had already stripped the bolt.. So $600 for the pump and $600 for stuffing around with it..
If you remove the battery terminals for 10 mins or so and replace, it all seems to work but still wont pump, after a minute or so, it comes back to the same problems as you started with.. Michael
Patrol 4.2TDi 2003

Retired 2016 and now Out and About!

There's time to rest when you're dead,
Get out and do something instead!

Member
My Profile  My Blog  My Position  Send Message

AnswerID: 345441

Follow Up By: blown4by - Thursday, Jan 22, 2009 at 16:08

Thursday, Jan 22, 2009 at 16:08
Yeah I tried a search first. Maybe I did it wrong but nothing came back.
Thanks everyone, I will try all the suggestions and hopefully will be able to come back and say it is working.
I didn't buy the extended warranty mainly because it was via an Insurance Company and it sounded like too many things were not covered.
0
FollowupID: 613492

Reply By: Member -Dodger - Thursday, Jan 22, 2009 at 16:20

Thursday, Jan 22, 2009 at 16:20
Te relay for the sub tank on my Patrol is under the passenger seat maybe someone has bumped a wire off .
I too had problems with the sub tank pumping over and found that an additional earth from tank to chassis and chassis to body plus an additional earth to the main battery fixed it.
To reset the relay and mini pooter just disconnect the batteries completely for 10 min whilst you have a beer/Cuppa. Otherwise it may be the changeover pump has died.
I used to have a handle on life, but it broke.

Cheers Dodg.

Lifetime Member
My Profile  Send Message

AnswerID: 345527

Sponsored Links

Popular Products (13)