Landcruiser 12HT stops

Submitted: Saturday, Mar 07, 2009 at 01:03
ThreadID: 66587 Views:1574 Replies:4 FollowUps:1
This Thread has been Archived
Hi,
any experts out there, my 12HT cruiser likes to stop when idling on a step hill for a few minutes. Once moved to flat surface its Ok. If I keep reving it gets rough but does not stall, but if left to idle then it stops.
I though it could be a dirty fuel tank ?
Any ideas ?
Thanks
Back Expand Un-Read 0 Moderator

Reply By: ross - Saturday, Mar 07, 2009 at 08:30

Saturday, Mar 07, 2009 at 08:30
I doubt its dirty fuel as you have a good filtration system and if it was the fuel ,it would do it all the time.

My guess is it could be the fuel feed pump attached to the side of the injection pump.(its connected to the priming pump)
Parking on a hill might be too much for the feed pump at idle.
A fuel injection shop could remove it(or its a simple job to remove yourself) and test the pumping pressure
AnswerID: 352679

Reply By: Member - Phil G (SA) - Saturday, Mar 07, 2009 at 09:05

Saturday, Mar 07, 2009 at 09:05
May be the low oil pressure cutout?
AnswerID: 352683

Follow Up By: ross - Saturday, Mar 07, 2009 at 12:24

Saturday, Mar 07, 2009 at 12:24
There a stop lever on the pump,I was wondering if its cutting the fuel to the pump because its out of adjustment/loose.
0
FollowupID: 620869

Reply By: Member - DOZER- Saturday, Mar 07, 2009 at 13:32

Saturday, Mar 07, 2009 at 13:32
Its fuel related due to stopping on hill...there is a restriction in the tank or pump or filters, or the lift pump is weak or a combo of all....add hill and it wont suck enough to run properly or keeprunning at idle...start with the fuel filter, if no change the in- tank filter, then the fuel pump inlet filter and if all that doesnt solve it, the lift pump.
Andrew
b4 you bag me out, walk a mile in my shoes, then your a mile away and have my shoes :)

Member
My Profile  My Position  Send Message
Classifieds: Bt50/Ranger Speedy grande2 18x8 alloys (x4), Landcruiser 200 series/100 series 4 alloy rims with tyres and nuts GC

AnswerID: 352720

Reply By: philldeb - Saturday, Mar 07, 2009 at 13:43

Saturday, Mar 07, 2009 at 13:43
Could be low oil pressure at idle. Kick up your idle screw 100 rpm to see wot it dose then
AnswerID: 352722

Sponsored Links

Popular Products (14)