04 Patrol fuel filter harness

Submitted: Monday, May 11, 2009 at 09:05
ThreadID: 68711 Views:3661 Replies:1 FollowUps:4
This Thread has been Archived
Just changed all the filters on the 04 Patrol
But had no idea how to the fuel filter sensor so just left it on and connected the new filter in a difficult.
The connect has a black piece attached to the brownish coupling but I had no hope of working it out.
Can someone please help?

Back Expand Un-Read 0 Moderator

Reply By: Member - Malcolm (Townsville) - Monday, May 11, 2009 at 09:21

Monday, May 11, 2009 at 09:21
Malcolm1

The easiest way to change the fuel filter on a Nissan Patrol is to remove the two hoses and two hold down bolts. Unclip the electrical connection at the bottom of the filter. Place the filter bracket in the vice and remove the water sensor from the bottom. Now remove the filter from the bracket. Screw the water sensor to the new filter (hand tight). Fill the filter with diesel fuel and screw to the bracket. Tighten with tool 2/3 turn. Replace on vehicle and fasten two bolts. Replace inlet hose and tighten. Pump the filter with finger over outlet pipe. Every now and then remove finger to expel air. When fuel is expelled replace outlet hose, tighten and continue pump until hard.

And this is the part you wanted, reconnect the electrical connection at the bottom of the filter. Make sure you have it the correct way around. Also make sure it is the correct connection. It should just click in.

If you ever have problems with hard starting, have to keep pumping filter, etc. replace the fuel filter.

Malcolm
living the 'good life'

Lifetime Member
My Profile  My Blog  Send Message

AnswerID: 364252

Follow Up By: Member - Malcolm (Townsville) - Monday, May 11, 2009 at 09:27

Monday, May 11, 2009 at 09:27
P.S. and only use GENUINE NISSAN FILTERS.

Malcolm
living the 'good life'

Lifetime Member
My Profile  My Blog  Send Message

0
FollowupID: 631948

Follow Up By: Malcolm1 - Monday, May 11, 2009 at 09:42

Monday, May 11, 2009 at 09:42
Malcolm,

Thanks its that that I couldn't unclip.
I just undid the filter from the bracket raised it up and put it in some multi grips and unscrewed the filter from the drain cock but left the sensor on.
Then I wound the new filter back on.
But it is that sensor clip I could not work out and I didn't want to break it by just pulling it apart.
It just has the 2 wires going in and out of the connector but I'm really stumped how to undo it as it doesn't just un-clip there seems to be another little trick to getting it undone.


Regards


Malcolm
0
FollowupID: 631950

Follow Up By: Member - Malcolm (Townsville) - Monday, May 11, 2009 at 11:02

Monday, May 11, 2009 at 11:02
OK ...

At the edge of the clip is a little 'catch' (about 3-4mm) using a small screwdriver. or other pointy object, push that clip in at the same time as pulling the connector apart.

Have a look for a similar connector e.g front of intercooler and practice on that.

Took me a while to work them out as well.

Malcolm
living the 'good life'

Lifetime Member
My Profile  My Blog  Send Message

0
FollowupID: 631953

Follow Up By: Malcolm1 - Monday, May 11, 2009 at 11:14

Monday, May 11, 2009 at 11:14
many thanks I'll give a go
0
FollowupID: 631957

Sponsored Links

Popular Products (14)