2.5 ltr d22 navara problems

Submitted: Sunday, May 24, 2009 at 21:39
ThreadID: 69145 Views:7536 Replies:3 FollowUps:0
This Thread has been Archived
Hi everyone

My mate and myself purchased 2 new navara's d22 2.5 common rail, mine has been faultless in every way but my mates has been constantly going into limp mode or safe mode i think its called. has any one heard of this happening to others or any idea's on what he can do about it. When he took it back to the dealer they kept it for 4 days then told him they cant find anything wrong. any advice is most welcome. Regards Grant M
Back Expand Un-Read 0 Moderator

Reply By: Member - Graham H (QLD) - Sunday, May 24, 2009 at 21:51

Sunday, May 24, 2009 at 21:51
Perhaps the nissan forums would be a better place to ask

Start at www.patrol.com.au




AnswerID: 366549

Reply By: Patrol22 - Sunday, May 24, 2009 at 22:56

Sunday, May 24, 2009 at 22:56
Yes a friend has a D40 2.5 auto identical to mine and he had this problem. Dealer changes the common rail, injectors etc and then finally change the entire fuel system and ECU I believe but don't really remember the extent of the equipment change. If you post an email address I will ask him to respond to you directly. Like you I've not experienced the problem.

You might also like to ask you question at the following sites as well:

Pathfinder Forum
Club Frontier International
Navara Asia

All these forums will be able to answer questions on the 2.5 ltr diesel which is used in the D22, D40 Navaras and the R51 Pathfinder.

Cheers
Pete
AnswerID: 366556

Reply By: 98nav - Monday, May 25, 2009 at 23:53

Monday, May 25, 2009 at 23:53
thanks very much i will follow up those other forums and see what i can find out.
Regards Grant M
AnswerID: 366744

Sponsored Links

Popular Products (13)