AUSCRUISE Cruise Control by Autron fitted 100 searies 1HZ engine

Submitted: Monday, Jun 15, 2009 at 13:59
ThreadID: 69837 Views:3671 Replies:3 FollowUps:3
This Thread has been Archived
HI All,
Have any of our members had the above cruise control fitted to a standard diesel 100series, if so have you had any problems as the wife and I used ours for the first time yesterday and it actually caused the throttle to jam open as we travelled the freeway then eventually the joining chain that connects to the throttle assembly broke allowing throttle to return to normal. The installer saiid this is the way we always install this device, Toyota have told them untill they come up with a better way of connecting this it is to remain disconnected. I was wondering if you may have had or heard of anything similar happening regards Alan W.A.

Lifetime Member
My Profile  My Blog  Send Message

Back Expand Un-Read 0 Moderator

Reply By: Krakka - Monday, Jun 15, 2009 at 14:04

Monday, Jun 15, 2009 at 14:04
I have had this cruise control fitted to our standard 100s 1hz for 6yrs, only problem in that time was the actuator failed about 1yr ago. Had that replaced and works great.

Regards

Krakka
AnswerID: 370070

Reply By: Member - Alan John C (WA) - Monday, Jun 15, 2009 at 14:46

Monday, Jun 15, 2009 at 14:46
I have just been told by Toyota that the chain setup used by their installer breakes frequently and Autron know about it and have informed the installer that they should use the same asembly that is used on rev limitors for mine sites this allows two cables to be attached therefore no need for chain and solves the problem. Our Toyota dealer is now filing a full insident report due to the fact the installer new the problem but failed to carry out modification to this system Alan WA.

Lifetime Member
My Profile  My Blog  Send Message

AnswerID: 370078

Reply By: Voxson - Monday, Jun 15, 2009 at 14:53

Monday, Jun 15, 2009 at 14:53
I am getting one fitted to my 105 standard on Thursday.
Now my fingers are crossed lol...
AnswerID: 370080

Follow Up By: Krakka - Monday, Jun 15, 2009 at 14:58

Monday, Jun 15, 2009 at 14:58
Nice to see you have crossed over from the darkside Voxson. LOL.

Krakka
0
FollowupID: 637452

Follow Up By: Member - Alan John C (WA) - Monday, Jun 15, 2009 at 15:07

Monday, Jun 15, 2009 at 15:07
JUst remember nothing wrong with the product I have one in my hylux and love it. The problem will be with the installer and their attitude regards Alan

Lifetime Member
My Profile  My Blog  Send Message

0
FollowupID: 637453

Follow Up By: Voxson - Monday, Jun 15, 2009 at 15:58

Monday, Jun 15, 2009 at 15:58
Yeah Krakka.

It was the only true dinosaur on the market which was good value for money.
Kitted out properly it should be a nice touring bus.
0
FollowupID: 637462

Sponsored Links

Popular Products (14)