Engine Saver installation 02 GU 4.2 TD

Submitted: Tuesday, Jun 16, 2009 at 12:34
ThreadID: 69867 Views:1987 Replies:3 FollowUps:0
This Thread has been Archived
Afternoon all,
I have recently purchased the above two in one unit.
I have successfully connected the low water sensor however, would like to know where others have connected their temp sensor.

Any suggestions or photo's would be greatly appreciated.

Thanks
Chris.
Back Expand Un-Read 0 Moderator

Reply By: Member - Rodney B- Tuesday, Jun 16, 2009 at 13:47

Tuesday, Jun 16, 2009 at 13:47
Chris
Recently fitted it to my 80 series LC and tried the temp sensor in 3 different places until I was happy with it. Suggest you keep it away from the exhaust system as the radiated heat registers on the sensor. I found a spot below my inlet manifold at the rear of the head which gives a better indication of the head temperature. Not familiar with the Nissan head but I am sure you will find a tapped hole somewhere on the head.
I found the unit is brilliant and does what they say (which is a turn up for a change).

Cheers
AnswerID: 370309

Reply By: Member - Graham H (QLD) - Tuesday, Jun 16, 2009 at 23:09

Tuesday, Jun 16, 2009 at 23:09
Mine is on a tapped hole at the front of the head on a 100ser.

Was too hard to get it at the back of the head.

Engine runs at 78-82deg whilst towing nearly 3 tonne

There was some pics posted by Richard Kovac about a week ago that shows it on a Cruiser also.



AnswerID: 370434

Reply By: putrol - Wednesday, Jun 17, 2009 at 15:12

Wednesday, Jun 17, 2009 at 15:12
i put one in my gu but i bought the inline version & just an 1" out of the top radiator hose & slip it in very neat & easy to fit
AnswerID: 370513

Sponsored Links

Popular Products (14)