New Challenger.

Submitted: Monday, Jan 18, 2010 at 20:13
ThreadID: 75311 Views:2301 Replies:2 FollowUps:3
This Thread has been Archived
I picked up my new ride today! It is great so far. Taking it on a 900km round trip tomorrow so I should have a better opinion after that. Now I just have to sell my old on. It is advertised in the trader if anyone is interested
Back Expand Un-Read 0 Moderator

Reply By: Mr Z - Monday, Jan 18, 2010 at 21:05

Monday, Jan 18, 2010 at 21:05
I look forward to hearing your opinion after tomorrow.
I am considering one of these as a cheaper alternative to a Prado
AnswerID: 400077

Reply By: flashcher - Tuesday, Jan 19, 2010 at 20:40

Tuesday, Jan 19, 2010 at 20:40
Well I must say that the car is a dream to drive. The back seats are comfortable and so must be the third row seats as the niece didn't want to get out when we had pit stops. On the trip over we averaged 11l/100km and on the way back it got down to 10.3l/100km. I think the difference would be us climbing over two mountains on the way over plus the motor would need a little running in I would think. The only problem from todays run is that the speedo is out. When the speedo say 110 - it is only doing 101. We checked this on the Navman and the two mobile phone navigators in the car. All the portable devices read the same speed. Hubbie also did the 5km speed check thing and it was over by about 150 meters. Will give the local service dept a call tomorrow. Otherwise it is a great car to drive, very comfortable.
AnswerID: 400234

Follow Up By: Member - Graham H (QLD) - Tuesday, Jan 19, 2010 at 20:47

Tuesday, Jan 19, 2010 at 20:47
Its legal for them to have up to 10% error in that way.


0
FollowupID: 669359

Follow Up By: flashcher - Wednesday, Jan 20, 2010 at 15:12

Wednesday, Jan 20, 2010 at 15:12
Yes Graham that is correct. I spoke with the service dept. today and they said the Australian Design Rules allow for 10% + 4.
At least I know why every kept overtaking me now...lol.
0
FollowupID: 669465

Follow Up By: Wilk0 - Wednesday, Jan 20, 2010 at 20:50

Wednesday, Jan 20, 2010 at 20:50
Hi flashcher,

Ive got the same issue with the speedo with my Pajero but otherwise its a great vehicle.

Cheers Wilko
0
FollowupID: 669523

Sponsored Links

Popular Products (14)