OziExplorer & Moving Map

Submitted: Monday, Mar 15, 2010 at 20:47
ThreadID: 76900 Views:3155 Replies:6 FollowUps:12
This Thread has been Archived
I run OziExplorer on a Laptop and use a Bluetooth GPS. It all works well but there is one annoyance. When I load NatMap 2008 and connect to the GPS the connection is fine but the image /GPS icon bounces around the screen.

Any ideas as to why and what can be done to rectify this would be appreciated.

Thanks
WBS
Back Expand Un-Read 0 Moderator

Reply By: MrBitchi (QLD) - Monday, Mar 15, 2010 at 21:14

Monday, Mar 15, 2010 at 21:14
The quick answer is don't use NatMap. Ozi is much better IMO.

Also, I gave up on my bluetooth GPS and now use a USB connected BU-353. The bluetooth one kept going to sleep and running it's batteries flat at the most inconvenient times :-((
AnswerID: 408991

Follow Up By: WBS - Monday, Mar 15, 2010 at 22:00

Monday, Mar 15, 2010 at 22:00
I am pretty confident there is nothing wrong with the Bluetooth GPS as it works just fine with my PDA and has a long battery life, although I have it connected via cigarette plug when in use for extended periods.. I have a feeling in my waters that perhaps its the Bud setting or something similar in the co furation file but I haven't been able to pin it down.

WBS
0
FollowupID: 678976

Follow Up By: WBS - Monday, Mar 15, 2010 at 22:01

Monday, Mar 15, 2010 at 22:01
Geez I wish I'd learnt to type properly. Try "Baud" setting.

WBS
0
FollowupID: 678978

Follow Up By: Sand Man (SA) - Monday, Mar 15, 2010 at 22:18

Monday, Mar 15, 2010 at 22:18
MrBitchi,

I disagree with your comment.

Natmap, or any other digital raster map used by OziExplorer will have no impact as to how the moving map function will work.
In fact OziExplorer on its own does not have a map reference source.
It must have a digital raster mapset such as Natmap Premium or Hema maps.

My guess is, the laptop "thinks" the GPS is a mouse and thus causes the problem described.

Bill.

Bill


I'm diagonally parked in a parallel Universe!

Member
My Profile  My Blog  My Position  Send Message

0
FollowupID: 678988

Follow Up By: MrBitchi (QLD) - Tuesday, Mar 16, 2010 at 08:36

Tuesday, Mar 16, 2010 at 08:36
Bill, it's not thr NatMap mapset I'm referrring to. It's the NatMap PROGRAM.
I know Ozi doesn't include it's own maps, I have it running on my laptop along with some 12GB of maps of various types.

WBS, if the baud rate was wrong then the program would not even talk to the GPS. Maybe a driver issue in NAtmap. Try selecting a generic GPS as type, or re-pair the GPS with your laptop, using a different virtual port.
0
FollowupID: 679014

Reply By: StormyKnight - Monday, Mar 15, 2010 at 21:34

Monday, Mar 15, 2010 at 21:34
If you have a mouse attached to your laptop, try it without it plugged in. Sometimes a program will get confused as to which com port the GPS is on.


Can you confirm that NatMap has detected the correct port for your GPS?


Cheers

AnswerID: 408997

Follow Up By: WBS - Monday, Mar 15, 2010 at 22:03

Monday, Mar 15, 2010 at 22:03
I can't see how the Bluetooth would affect the USB connection or visa versa but anything is worth a try. I get back to you on that one

thanks
WBS
0
FollowupID: 678979

Follow Up By: WBS - Monday, Mar 15, 2010 at 22:05

Monday, Mar 15, 2010 at 22:05
I'm pretty sure the GPS is detected as I can see the NMEA data stream downloading from the GPS. As I said above, I'm suspicious I've got the wrong Baud setting or something equaly simple.

Thanks
WBS
0
FollowupID: 678980

Follow Up By: Sand Man (SA) - Monday, Mar 15, 2010 at 22:27

Monday, Mar 15, 2010 at 22:27
WBS,

If you think you may have the wrong baud setting, change it to 2400 baud which is plenty fast enough for acurate communication between the GPS and the Laptop via the com port.

When using a com port connection, a common fault is the laptop is fooled into thinking the GPS is a mouse and the pointer dives all around the screen.

When I was using a com port connected GPS mouse I had this problem.
You could sometimes overcome it by booting the PC before connecting the GPS mouse, but in the end I replaced the Com port connected mouse with one that used a USB port connection.


Bill.

Bill


I'm diagonally parked in a parallel Universe!

Member
My Profile  My Blog  My Position  Send Message

0
FollowupID: 678991

Reply By: Member - Chris & Debbie (QLD) - Monday, Mar 15, 2010 at 21:46

Monday, Mar 15, 2010 at 21:46
Is it OK while you are moving? I have also had trouble with a bluetooth GPS, as some of the cheaper ones can not determine that you are stationary and lock in one position, therefore the icon drifts around the screen. I gave up on the bluetooth GPS and with a USB BU-353 GPS Mouse.
Chris
VKS737 - Mobile 1089
-------------------------------------------

Member
My Profile  My Blog  My Position  Send Message

AnswerID: 409000

Follow Up By: WBS - Monday, Mar 15, 2010 at 22:08

Monday, Mar 15, 2010 at 22:08
I don't use the laptop while mobile, or at least I haven't as yet as I have a PDA that I use while mobile, so I can't answer that question but I would assume it would be ok once mobile. I'll give it a try and get back to you.

I only was thinking of using the laptop as a backup should the PDA spit the dummy some time.

Thanks
WBS
0
FollowupID: 678984

Reply By: Mandrake's Solar Power- Monday, Mar 15, 2010 at 22:26

Monday, Mar 15, 2010 at 22:26
Have you checked the Ozi website ? I am sure this is a problem that has a fix in the FAQs - The laptop thinks the GPS is a mouse and the incoming data stream makes the pointer jump all over the screen - My USB one does it unless I start the laptop with it plugged in !!

Cheers

Steve

AnswerID: 409013

Follow Up By: GerryP - Monday, Mar 15, 2010 at 22:43

Monday, Mar 15, 2010 at 22:43
Hey Steve,

That's interesting as I have to plug my GPS in AFTER I start Ozi up. If I start Ozi with it already connected, then the pointer jumps around all over the place - as some have suggested, it thinks is a mouse and responds to the incoming data stream accordingly.

Cheers
Gerry
0
FollowupID: 678999

Reply By: WBS - Monday, Mar 15, 2010 at 23:42

Monday, Mar 15, 2010 at 23:42
Thank you for all your replies. I have had another look at this phenomenon and now realise that the map and the GPS cursor move about together (in unison even), so it may have something to do with the whole set up as opposed to it being just a GPS problem.
I've fiddled with the baud rates (lowering and raising) with no change.
I've disconnected the mouse and rebooted with no change.
My next trick will be to connect my trusty old Etrex and see what happens.
If after that I haven't resolve this I will get in touch with OziExplorer themselves to see what they have to say.

I'll report back if and when I get an answer.

Thanks again to all respondents
WBS
AnswerID: 409022

Follow Up By: Member - Niss42 - Tuesday, Mar 16, 2010 at 08:43

Tuesday, Mar 16, 2010 at 08:43
WBS,

Try this, (From OZI website)

* A method which should stop it happening is included below. We got this from a newsgroup and have had reports that it does work.

1. Boot the computer with the GPS receiver attached. The cursor will be jumping around and all sorts of unwanted stuff will be happening.
2. Disconnect the GPS. The computer will settle down.
3. Select Control Panel - System - Hardware - Device Manager.
4. Click on the "+" next to Mice and other pointing devices.
5. Click on "Microsoft Serial Ball Point" - This is what Windows 2000/XP thinks that your GPS receiver is.
6. Select "Actions" and then "disable".
7. Click "OK" to close each window
8. Reboot the computer with the GPS attached. All should be well.


Cheers,
niss42
Missn in da Nissan

Member
My Profile  Send Message

0
FollowupID: 679015

Follow Up By: WBS - Tuesday, Mar 16, 2010 at 10:25

Tuesday, Mar 16, 2010 at 10:25
Thanks Niss42,
I did as you advised above but as with all the best laid plans, it did not go according to plan.

Firstly I did not have a Microsoft Serial Ball Point in my list. As a test I disabled my usb mouse while I was in there and just used my Touchpad. Result = no change.

I then connected my trusty old Garmin Etrex as an NMEA GPS . Result = all is beauty and light. It is as steady as a rock!

I now have to recant the statement I made about the Bluetooth GPS not being the problem. It may not be the GPS that is the problem but somehow it clashes with XP.

Maybe I should try disabling the Touchpad next as that may be the problem

WBS
0
FollowupID: 679023

Follow Up By: Member - Niss42 - Tuesday, Mar 16, 2010 at 11:17

Tuesday, Mar 16, 2010 at 11:17
WBS
Try this From OziExplorer Support page.

GPS Port Checker

This is a simple program which scans the ports on a PC and reports their status. It also scans all the ports at all baud rates to see if there is a GPS connected. Help is provided with the program.

The program can be run by clicking on the link below and choosing the run option (if your web browser supports this) or saved to a folder on your PC and run from there.

Go to the GPS Port Checker program page.


I am using a USB GPS without any problem, however 10+ years ago I had the same issue as you using a Garmin XL12 which was fixed using the previous method.

Good luck
niss42
Missn in da Nissan

Member
My Profile  Send Message

0
FollowupID: 679029

Reply By: bobj - Tuesday, Mar 16, 2010 at 22:12

Tuesday, Mar 16, 2010 at 22:12
Hi You will find that the GPS mouse dosen't have a filter built in to stop the movement as with a handheld Gps. Have been in touch with Globalsat re this problem and was told about the filter. The GPS mouse can be reconfigured to stop the movement but when you turn it off it reverts back to the original settings. Also the movement will be worse if you have OZI setup with more map showing in the direction of travel so leave the setup in the centre then the pointer will only rotate around your position not all over the map when stopped, work perfectly when moving at anthing over 1 Kph. Just my 2 bobs worth.

Bob
AnswerID: 409158

Sponsored Links

Popular Products (14)