HILUX D4D KUN 3LT 2006 NO POWER

Submitted: Friday, Apr 30, 2010 at 00:28
ThreadID: 78094 Views:10344 Replies:4 FollowUps:1
This Thread has been Archived
HAS ANY ONE EXPERIENCED POWER PROBLEMS WITH THESE VEHICLES
NOT INJECTORS FUEL FILTER HAS BEEN CHANGED AIR CLEANER OK STRAINER IN TANK CLEAN , TAKE OUT AIR CLEANER ELLIMENT AND ENGINE WON'T REV PAST 900 RPM. COULD IT BE A MAF SENSOR OR IS THERE A SWITCH OR VALVE IN PUMP THAt could cause the problem.
WOULD APPRECIATE ANY FEED BACK dmech
Back Expand Un-Read 0 Moderator

Reply By: Ozhumvee - Friday, Apr 30, 2010 at 06:56

Friday, Apr 30, 2010 at 06:56
Sounds just like what happened to a mate after a crook tank of fuel, replaced all four injectors and away it went, big dollars though.
What does the stealer say?
Peter
1996 Oka Motorhome

Member
My Profile  My Position  Send Message

AnswerID: 414777

Reply By: Member - Tour Boy ( Bundy QLD) - Friday, Apr 30, 2010 at 07:33

Friday, Apr 30, 2010 at 07:33
As Pete said probably bad fuel. Not a case so much of dirty fuel but poor quality. Wasn't woolies on the last fill by any chance?

Put it on the diagnosis computer and see what it tells you.

Cheers
Dave
Cheers,
Dave
2010 Isuzu FTS800 Expedition camper
2015 Fortuner
Had 72 cruisers in my time

Lifetime Member
My Profile  My Blog  Send Message

AnswerID: 414782

Reply By: Redback - Friday, Apr 30, 2010 at 07:53

Friday, Apr 30, 2010 at 07:53
Turbo maybe? this will cause those symtoms, does it have a turbo modulator? if so check the hoses to it, could be the MAF but I doubt it, they usually don't have that much of an affect, the MAF sensor can be cleaned, go to a parts shop and get some MAF cleaner, spray the element and leave to dry, then re-install (DO NOT TOUCH THE ELEMENT)

Check the hoses to the turbo from the intercooler, these can delaminate, causing lose of power.

Baz.

AnswerID: 414786

Follow Up By: Redback - Friday, Apr 30, 2010 at 08:08

Friday, Apr 30, 2010 at 08:08
I forgot to add there is another sensor in the mix, it's called an AAP sensor (Ambient Air Pressure) clean that one too, it will be in the airbox.

If the turbo is faulty it will send the car into limp mode, not allowing you to go over 10kph.

Baz.
0
FollowupID: 684984

Reply By: Member - Alan John C (WA) - Friday, Apr 30, 2010 at 11:29

Friday, Apr 30, 2010 at 11:29
Dmech hope you havn't run any Bio Fuel in it as this engine is to Hi Tech for this fuel and the easy thing is take to Toyota it take them ten minutes to plug in and eliminate alot of your concern.

Lifetime Member
My Profile  My Blog  Send Message

AnswerID: 414823

Sponsored Links

Popular Products (14)