GU Sub Tank

Submitted: Wednesday, Oct 15, 2003 at 20:18
ThreadID: 7844 Views:1251 Replies:3 FollowUps:0
This Thread has been Archived
Hi everybody my 2002 GU series 3 sub tank light came on today, checked the fuse it's ok have it booked into Nissan next week to fix it but was hoping someone might know what may have caused the light to come on just so I will Know. Nissan want it most of the day.
Back Expand Un-Read 0 Moderator

Reply By: Member - Errol (WA) - Wednesday, Oct 15, 2003 at 20:58

Wednesday, Oct 15, 2003 at 20:58
Try cleaning the blaides on the fuse . Had the same prob out in Rudel River nat park , thats all i did and prob went away . Cheers Errol .Why go overseas when you can ExplorOz
ERROL
AnswerID: 33952

Reply By: The Crow - Thursday, Oct 16, 2003 at 13:42

Thursday, Oct 16, 2003 at 13:42
Problem solved I disconnected the battery and the light reset and the pump now works again will still take to nissan to check out.
AnswerID: 34030

Reply By: Member - Wayne- Saturday, Oct 18, 2003 at 11:19

Saturday, Oct 18, 2003 at 11:19
I have had this problem TWICE in one week. Its a nuisance to drive around with fuel in a tank you cant use.

Had the battery disconnected (because thats the fix) as its an earthing problem. Shame that I lost all the trip meter info and had to reset the radio presets etc. The problem was linked to the fact that the rear light set (in the bumper) fell out whilst driving on the bitumen!!!!

This time I have been told that it is an earth problem and a simple earth strap can be fitted to overcome it. Thanks for supplying the necessary equipment on a vehicle to make it work NISSAN!! NOT!

If you just want to disconnect the earth each time then thats the simple fix, otherwise get it earthed properly with the strap.
AnswerID: 34262

Sponsored Links

Popular Products (13)