Codan HF trouble

Submitted: Saturday, Jun 26, 2010 at 19:10
ThreadID: 79656 Views:2655 Replies:4 FollowUps:2
This Thread has been Archived
G'Day
Have a Codan 8525. You good blokes have helped me a lot with it...
Returning from 3 months up North, at Kulgera, the radio started emitting a rapid continuous beep-beep-beeping. No buttons would work on the RC head - not even the off button. Had to turn it off by pulling the supply fuse. Inserting the fuse again put the radio on (channel light and HF hiss) but soon as I pressed any button the beep-beep-beep-beeping starts again.
Obviously something wrong - anyone know and can advise please.
Many thanks
Jedo
Back Expand Un-Read 0 Moderator

Reply By: rescue134 - Saturday, Jun 26, 2010 at 19:27

Saturday, Jun 26, 2010 at 19:27
sounds like low power (voltage)to me. make shore there are good connections at battery and at set.
kevin
AnswerID: 422220

Follow Up By: blue one - Saturday, Jun 26, 2010 at 20:17

Saturday, Jun 26, 2010 at 20:17
Second that
0
FollowupID: 692584

Follow Up By: Jedo_03 - Saturday, Jun 26, 2010 at 20:23

Saturday, Jun 26, 2010 at 20:23
Thanks rescue and blue one...
Will check all supply lines and connections in the morning...
Much appreciated
Jedo
0
FollowupID: 692586

Reply By: Member - Mark E (VIC) - Saturday, Jun 26, 2010 at 21:03

Saturday, Jun 26, 2010 at 21:03
The on/off pad is a well know wear point on these radios and may well be faulty. Unfortunately there isn't much of a fix known, apart from inserting another more crude style of on/off button. The face panels with switch membrane are extremely hard to find and the radio model is now so long in the tooth the Codan no longer support spare parts for it.

If you scour eBay long enough, you may just find another remote head, but I would try the simple things mentioned above re the power and earth wires and all connections. Also double check all wires in the "D" style plugs that plug into the back of the set and antenna control cable....these have been know to wear after years of corrugations etc....

Let us know how you go....

Cheers,

Mark
AnswerID: 422226

Reply By: Stu & "Bob" - Saturday, Jun 26, 2010 at 21:55

Saturday, Jun 26, 2010 at 21:55
G'day Jedo,

Does the display show anything when this beep-beep-beep happens? Mine was doing that and the display had "UL" on it.

If it is showing a "UL" it is saying that the synthesizer is unlocked and it will have to visit a repair shop to fix.

Fortunately it was a inexpensive repair, about $50 from memory.

HTH
AnswerID: 422228

Reply By: Signman - Sunday, Jun 27, 2010 at 10:47

Sunday, Jun 27, 2010 at 10:47
I reckon the front 'panel' could be cactus.
I had similar probs. withy our 8525, but luckily managed to procure a brand new panel. Replaced it and now all good.
The replacement parts are as scarce as 'rocking horse manure'- but if your desperate- I may be able to give you a lead.

AnswerID: 422255

Sponsored Links

Popular Products (14)